WordPress.org

Forums

Advanced iFrame
[resolved] Update settings - end up on a 404 page (11 posts)

  1. mashedspuds
    Member
    Posted 1 year ago #

    When I try to save any options (say disable the scrollbar), I'm thrown to a 404 page after I hit update settings. Typically the url being:

    http://mydomain.com/wp-admin/options-general.php?page=advanced-iframe.php

    http://wordpress.org/plugins/advanced-iframe/

  2. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    This is actually the right url. Have you protected this folder somehow?
    Can you save options on other 3rd party plugins?

    In the meantime you can use the shortcode attributes to do the setup.

  3. mashedspuds
    Member
    Posted 1 year ago #

    Protected WP Admin with directory password. Other plugins work ok behind this extra layer of security.

  4. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    can you please give me an example plugin where this works?
    Then I can check what they make different.

    Because all the plugins I have installed use the way I do.

    Best, Michael

  5. mashedspuds
    Member
    Posted 1 year ago #

    Hi. I'm using the Ad Injector plugin.

  6. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    I have checked the code of the ad injector plugin and it does it exactly the same way.
    How do you setup the directory password? With a .htaccess?
    Maybe I can reproduce this.

    Best, Michael

  7. mashedspuds
    Member
    Posted 1 year ago #

    Hi. I followed the steps in this article, plus I had to include some code in the .htaccess file (on line 1 before all rules):

    ErrorDocument 401 default

    Btw, I'm hosted at Namecheap if that helps.

    Thanks.

  8. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    Hi. I just protected my admin folder and I was able to save without problems.

    Maybe mod_security is the problem.
    Maybe
    http://wordpress.org/support/topic/solve-a-404-after-save-changes-from-options-permalinkphp?replies=12
    helps.

  9. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

  10. mashedspuds
    Member
    Posted 1 year ago #

    Thank you mdempfle for looking into this, and trying to recreate the problem.

    I'll try the solutions in the links provided, and let you know the outcome.

    Tony.

  11. mashedspuds
    Member
    Posted 1 year ago #

    [double post]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.