Support » Plugin: WP-Matomo (WP-Piwik) » Update resulted in an avalanche of error messages

  • christer_f

    (@christer_f)


    I updated the plugin from version 1.0.6 to 1.1.1 and got an avalanche of errors. This is my debug trace:

    [05-Jun-2020 14:59:26 UTC] Matomo: Scheduled tasks archive data
    [05-Jun-2020 14:59:31 UTC] Matomo: Scheduled tasks sync all sites and users
    [05-Jun-2020 14:59:31 UTC] Matomo: Matomo is now syncing blogId 1
    [05-Jun-2020 14:59:31 UTC] Matomo: Matomo site is known for blog (1)… will update
    [05-Jun-2020 14:59:31 UTC] Matomo: Changed global option last_tracking_settings_update: 1591369171
    [05-Jun-2020 14:59:31 UTC] Matomo: Apply changed settings:
    [05-Jun-2020 14:59:31 UTC] Matomo: Changed global option last_settings_update: 1591369171
    [05-Jun-2020 14:59:31 UTC] Matomo: Save settings
    [05-Jun-2020 14:59:31 UTC] Matomo: Matomo will now sync 4 users
    [05-Jun-2020 14:59:41 UTC] Matomo: Scheduled tasks update geoip database
    [05-Jun-2020 15:02:43 UTC] Matomo: Scheduled tasks update geoip database
    [05-Jun-2020 15:07:00 UTC] Matomo: Changed global option version_history: [“1.1.1″,”1.0.6″,”1.0.2″,”0.3.16″,”0.3.5”]
    [05-Jun-2020 15:07:00 UTC] Matomo: Changed global option core_version: 3.13.6-b1
    [05-Jun-2020 15:07:00 UTC] Matomo: Save settings
    [05-Jun-2020 15:07:03 UTC] WordPress database error Table ‘xxx.wp_matomo_archive_blob_2010_01’ doesn’t exist for query ALTER TABLE wp_matomo_archive_blob_2010_01 CHANGE name name VARCHAR(190) made by require_once(‘wp-admin/admin.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), WP_Hook->do_action, WP_Hook->apply_filters, WpMatomo->init_plugin, WpMatomo\Updater->update_if_needed, WpMatomo\Updater->update, Piwik\Access::doAsSuperUser, WpMatomo\Updater->WpMatomo\{closure}, WpMatomo\Updater::update_components, Piwik\Plugins\CoreUpdater\CoreUpdater::updateComponents, Piwik\Updater->updateComponents, Piwik\Updater->update, Piwik\Updater->executeSingleUpdateClass, call_user_func, Piwik\Updates\Updates_3_13_6_b1->doUpdate
    [05-Jun-2020 15:07:03 UTC] WordPress database error Table ‘xxx.wp_matomo_archive_numeric_2010_01’ doesn’t exist for query ALTER TABLE wp_matomo_archive_numeric_2010_01 CHANGE name name VARCHAR(190) made by require_once(‘wp-admin/admin.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), WP_Hook->do_action, WP_Hook->apply_filters, WpMatomo->init_plugin, WpMatomo\Updater->update_if_needed, WpMatomo\Updater->update, Piwik\Access::doAsSuperUser, WpMatomo\Updater->WpMatomo\{closure}, WpMatomo\Updater::update_components, Piwik\Plugins\CoreUpdater\CoreUpdater::updateComponents, Piwik\Updater->updateComponents, Piwik\Updater->update, Piwik\Updater->executeSingleUpdateClass, call_user_func, Piwik\Updates\Updates_3_13_6_b1->doUpdate

    After reloading the Dashboard error messages disappear, so maybe this is just a glitch in the update script

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.