Support » Plugin: Woocommerce Super Simple Tax Exemption » Update Required

  • Hello Bobbie, any chance of updating this plugin. There is a market for it. I used it a few years ago and want to use again, but can you update it so.we know it is secure?

  • The topic ‘Update Required’ is closed to new replies.