• VCareer

    (@vcareer)


    Hi, having problems updating, which I have not had a problem with before. Haven’t made any changes since our last update to file permissions, in fact don’t know where to even change that. here is the message:
    “Update Failed: The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.”

    https://wordpress.org/plugins/wordfence/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author WFMattR

    (@wfmattr)

    On the Wordfence options page, turn on “Disable config caching” and save the options. You might also need to manually remove configCache.php, or wait a while for it to become free before trying to update again. (The location is: wp-content/plugins/wordfence/tmp/configCache.php)

    I’m not sure why this currently happens on some servers, but our dev team is looking into it, and it will be fixed in a future version.

    -Matt R

    VCareer

    (@vcareer)

    Hi Matt,
    Thank you for the response, but neither seemed to work. We are still unable to update your plugin.
    When will the next update be available?

    Plugin Author WFMattR

    (@wfmattr)

    I don’t have a date for the next plugin update, but there should be one soon. In the meantime, you could try disabling the plugin, removing it, and installing it again.

    Settings are saved in the database and aren’t removed by default, so they should still be there when the plugin is reinstalled.

    Alternately, if there is something unusual that is wrong with the configCache.php file, you could ask the host to remove it for you. (That could help if permissions somehow got changed that you can’t remove it yourself, like if they misconfigured the web server temporarily, and then fixed it. If “Disable config caching” is enabled, the file shouldn’t be recreated.)

    -Matt R

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Update Problems’ is closed to new replies.