Support » Fixing WordPress » Update Post Clears Custom Taxonomies

  • Resolved Joshua David Nelson


    I have a custom post type “projects” with a custom taxonomy “project-type.” I’m using the custom meta boxes “plugin” (not a literal WP plugin) developed by Bill Erickson et al. I’m running the Thesis Theme framework 1.84. However, I don’t think it’s the plugin or the theme…

    If I try to select a project type taxonomy within the “project” post editor and hit update, the taxonomy isn’t updated. Worse yet, it clears all taxonomy values associated with that project. Oddly, I added a column in the admin screen to display the custom taxonomy values and I am able to update the taxonomy values via WP’s built-in quick edit feature.

    I’ve tried turning off all the plugins, I’ve tried new “project” posts, I’ve tried eliminating the code for adding the taxonomy column in the admin screen.

    This isn’t my first custom post or custom taxonomy, so I’m sure this code works and I can’t see any other issues anywhere. It is the only custom post/taxonomy for this WP install.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Here is the bulk of the custom post type and taxonomy code, the only thing missing is the custom metabox initialization which is called in a separate folder. Again, I don’t think it is the metabox plugin or the theme, I think it’s either an error with this code, my database somehow or a bug in WP (god forbid!)

    So, I need some function that will amend the save post function to include the custom taxonomy data. Right now the save_post function does not include custom taxonomies in a custom post type, and that is why it is clearing the data. Ideas?

    I just don’t know how exactly to parse the data in the custom taxonomies to compare/write the selected taxonomies to the specific post. I assume it is something to do with wp_set_post_terms().

    The odd part is that it works in the quick edit, I can’t figure that out, but it’s a moot point, really…

    Hi Joshua,

    I have exactly the same problem. Did you find a solution? Or did you find what causes this?

    Any help appreciated!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Update Post Clears Custom Taxonomies’ is closed to new replies.