Support » Plugin: WP Statistics » Update Plugin Not Working – IP.php on line 10

  • Resolved tankire

    (@tankire)


    incorrect line

    Parse error: syntax error, unexpected T_USE, expecting T_FUNCTION in /domain/public_html/wp-content/plugins/wp-statistics/vendor/s1lentium/iptools/src/IP.php on line 10

Viewing 15 replies - 1 through 15 (of 19 total)
  • same with me: this appears at the bottom of the home page
    Parse error: syntax error, unexpected T_USE, expecting T_FUNCTION in /var/sites/n/northstaffsbees.org.uk/public_html/wp-content/plugins/wp-statistics/vendor/s1lentium/iptools/src/IP.php on line 10

    same with me at the bottom of the page
    Parse error: syntax error, unexpected T_USE, expecting T_FUNCTION in /home/kzjmmwgc/public_html/wp-content/plugins/wp-statistics/vendor/s1lentium/iptools/src/IP.php on line 10

    I solved it by re-installing 10.3 version

    Plugin Contributor Greg Ross

    (@gregross)

    What version of PHP are you running?

    5.3

    Plugin Contributor Greg Ross

    (@gregross)

    Looks like the new IP library requires PHP 5.4, you have two choices:

    – upgrade to a newer version of PHP
    – downgrade to 10.3 and I’ll see if I can find a workaround, but it may end up need 5.4 anyway.

    I upgraded php to 5.4 & then tried to reinstall 11 but it keeps installing 10.3 so I will wait until it says “please update”

    Plugin Contributor Greg Ross

    (@gregross)

    I stopped the rollout of 11.0 while I update the version check and documentation, 11.0.1 will roll out in the day or two.

    thxs that would explain why I couldn’t install 11

    Will 11.01 work on PH 5.3? I can’t change the version of PHP – I’m on a shared server. It will get updated some day, but it’s out of my control.

    Plugin Contributor Greg Ross

    (@gregross)

    No, 11.0 and above will only work with PHP 5.4+.

    Since there have been no security patches in over two years for PHP 5.3, I’d suggest pushing your host to upgrade or find a new host.

    Of course you can stick with 10.3 which works with PHP 5.3, at this time there are no known security issues with 10.3 so while you’ll miss out on any new features and bug fixes, it’s still safe to use for the time being.

    how can I undo the upgrade and get the old version?

    Plugin Contributor Greg Ross

    (@gregross)

    10.3 download link: https://downloads.wordpress.org/plugin/wp-statistics.10.3.zip

    I would recommend upgrading your PHP though if possible.

    sbning

    (@sbning)

    Can you roll back to 10.3? 11.01 does not show widgets at all

    Plugin Contributor Greg Ross

    (@gregross)

    @sbning You can roll back by removing WP Statistics and then manually uploading the plugin. When you say it does not show widgets, do you mean the main WP Statistics menu is missing or just widgets on the overview page?

    If the menu is missing then check your PHP version, 11.0+ requires PHP 5.4.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Update Plugin Not Working – IP.php on line 10’ is closed to new replies.