WordPress.org

Support

Support » Plugins and Hacks » AWPCP - Classifieds Plugin » [Resolved] Update not working Fatal Error

[Resolved] Update not working Fatal Error

  • Just updated to new version of plugin. The Classifieds plugin went into inactive plugins. When I tried to manually install it I have this and none of the pages are there

    Hi I have exactly the same problem and do not use reCapTCHA plugin

    Fatal error: Cannot redeclare _recaptcha_qsencode() (previously declared in /home/sites/xxxxxx/public_html/wp-content/plugins/wp-recaptcha/recaptchalib.php:47) in /home/sites/xxxxxx/public_html/wp-content/plugins/another-wordpress-classifieds-plugin/vendors/recaptcha/recaptchalib.php on line 55

    http://wordpress.org/extend/plugins/another-wordpress-classifieds-plugin/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author awpcp

    @awpcp

    That seems like a plugin conflict– Here is an article about how to test for theme and plugin conflicts with AWPCP, which may help pinpoint the issue: http://www.awpcp.com/forum/viewtopic.php?f=3&t=3585

    Try that out and see what pops up as the conflicting element.

    Hi. I have the same problem. Same error.

    I have the same error, this is obviously a problem with the update as I’m sure many more people will come forward with exactly the same error – was working fine – updated – now not working and lost all my ads! Customers not happy.
    On a very active site it is not possible to disable all plugins and search for the conflict or change themes totally impraticle.

    Ok, I think I’ve found the problem and it’s not a conflict. Looks as though a while ago Recaptcha plugin may have been installed. I have deleted the folder ‘recaptcha’ via FTP access of Wp-content/Plugins directory manually. I then reinstalled AWPCP and it activated apart from a message saying you have to upgrade the AWPCP in the admin area. I followed the instructions and it has activated ok.

    Plugin Author awpcp

    @awpcp

    Hi everyone,

    This appears to be a conflict with WP-reCAPTCHA. We’re looking into it now.

    As for the “loss of ads” comment, your data is SAFE, even when you receive this fatal error. The data is not harmed by the upgrade in any way.

    @marcus: Are you running that plugin as well?
    @cocopops67: Are you saying that you have both plugins running now?

    I can verify I have the same problem with this upgrade.

    Plugin Author awpcp

    @awpcp

    Hi Jimmy,

    Can you please try the plugin conflict test as well? That is, unless you already know that you’re running WP-reCAPTCHA. Is that the case here?

    I only have the AWPCP plugin on. I never used recaptcha so deleted it from the file structure on server.

    Hi everyone,
    I also updated AWPCP, then any attempt to recover my admin session or to display my blog generated the following message:

    Fatal error: Cannot redeclare _recaptcha_qsencode() (previously declared in /homez.151/optimi/www/wp-content/plugins/another-wordpress-classifieds-plugin/vendors/recaptcha/recaptchalib.php:47) in /homez.151/optimi/www/wp-content/plugins/wp-recaptcha/recaptchalib.php on line 55

    Basically I am badly blocked…

    After reading your posts above, and since I use contact-form-7, contact-form-7-recaptcha-extension and wp-recaptcha plugins, should I do like cocopops67 i.e. simply delete these folders from FTP and “reboot”, or any other suggestion…?

    Your help greatly appreciated on this, thanks!

    Hi, I only deleted the folder on the server because I wasnt using it. I must have installed recaptcha a while ago but never used it, so deactivated and deleted. However the folder still remains in your plugins directory even if its deleted from your wordpress frontend.
    I would wait for official advice if you are still using recaptcha

    Plugin Author awpcp

    @awpcp

    Hi everyone,

    Looks like we have a patch for this. Pending testing, we’ll release it tomorrow (Friday).

    Thanks for your advise, cocopops67
    Anf for the good news, awpcp, appreciated too. Once the patch is ready tomorrow, if you could also instruct me on how I can somehow re-access my admin session that’d be great – at least if the patch’s implementation is to be done from in there.
    Cheers

    Plugin Author awpcp

    @awpcp

    The patch will be a full update from WordPress.org. Look for an updated version 3.0.1 on your Plugins dashboard.

    Is there a way I can somehow implement this full update via FTP, since I cannot access my WP dashboard anymore?

    ylec: Try using FTP to rename the existing folder to something like AWPCP.old, then see if you can access your site.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Update not working Fatal Error’ is closed to new replies.
Skip to toolbar