WordPress.org

Support

Support » Plugins and Hacks » Plugin Organizer » [Resolved] Update no good with Shopp ecommerce website.

[Resolved] Update no good with Shopp ecommerce website.

  • The update to V3.0 promptly disabled all my shopp ecommerce products and pages.
    Also will not enable a plugin on a specific page; already disabled in global plugins.

    After updating to WP 3.5.2, rolling back to the previous version of this plugin won’t work for me anymore either.

    My only option now is to disable the plugin – until these problems get fixed by the author.
    Been a really useful plugin – that is until latest update for this plugin & WP.

    http://wordpress.org/extend/plugins/plugin-organizer/

Viewing 15 replies - 1 through 15 (of 32 total)
  • Well, when you roll back, you need to roll back the database too … hope you have saved it …

    Thanks astrasuite,

    I was going to just wait for an update – but:
    One of the main reasons for using this plugin was to minimize home page loading time.
    I have about 40 other plugins used on my site, and while there are other ways to stop plugins loading on specific pages, this plugin was an easy and efficient way of doing this.

    May just restore the database – so I can maintain optimized page loading speed – while waiting for the update.

    Well, the old version was not broke, it was very good. It’s really a great plugin for those of us who value optimizing speed.

    I actually like the old look of checkboxes than the new one, but I’ll get used to it later, assuming it is working again.

    I really haven’t tested the new version completely as I only have a live site, but when I noticed that widgets from some plugins don’t seem to be activated/deactivated as they should be, I had to revert back or visitors will see it.

    So that’s the first thing I noticed, widget problem, and shortcodes too.

    Yep- like you astrasuite; seems some of the functionality is not present with the new version. I’m also uncomfortable that there is no setting page anymore.
    Now running previous version again (with WP V3.5.2).

    Just a warning to people wanting to revert to the previous version:
    be sure to completely delete V3.0 plugin-organizer from your plugins folder BEFORE restoring a previous version backup of your database – otherwise your site will break.

    Also this word of warning from Sarah: http://wpmu.org/think-twice-before-you-upgrade-that-wordpress-plugin/

    I am aware, but nevertheless repeatedly ignore these facts.
    We do tend to get lulled into a sense of false security; because of the ease of updating plugins from within WP-admin, and because 9 times out of 10 – there are usually no problems anyway.

    Mental note: WAIT – at least one week, before updating anything.
    Always check in the forums FIRST (not later) before updating any plugin.

    Plugin Author Jeff Sterup

    @foomagoo

    This update is a major change to the way everything works. Its supposed to be less confusing to disable and enable everything. All of the data has also been moved to custom post types and post meta. Make sure that everything got moved over correctly. So you are not able to enable a plugin after disabling it globally in the edit screen or it isn’t enabling on the front end?

    Plugin Author Jeff Sterup

    @foomagoo

    Also there is a settings page still. Its under settings now. And the URL admin moved to a Plugin Filters custom post type.

    Thanks for the info Jeff, and congratulations on your excellent work so far with this plugin.
    Loved the new interface – certainly less confusing than before.
    Unfortunately doesn’t work with my server/website configuration.

    I can give you access to our duplicate (test) website if you need to check why.

    Plugin Author Jeff Sterup

    @foomagoo

    That would be great. I haven’t had any issues with it that weren’t fixed prior to releasing so it’s hard to troubleshoot. You can email me the credentials. foomagoo@gmail.com.

    @jeff, I checked everything, they look the same as before. I knew about the Filter and Settings page, and new custom post type.

    Tried it twice, what I noticed easily is that even if enabled to be hidden in a post, a widget still shows up (e.g. Jigoshop e-commerce widget).

    With anther plugin whose shortcode is supposed to be activated in a post (and it shows as activated under PO), it didn’t show up, instead it showed the shortcode – i.e. [xxxxxxx]

    Thanks

    Plugin Author Jeff Sterup

    @foomagoo

    It looks like there was an issue with fuzzy url matching. I have fixed it and released version 3.0.1. Please download that version and see if it fixes your problem.

    Ok, I reinstalled again and checked if it solved the issue. It did not.

    So I went into more troubleshooting and noticed the following:

    In a sample of posts with the problems, the plugins to be enabled or disabled are not the same between the original PO and the new PO.

    The move to the new one did not go well it seems. Naturally, I hope it can be fixed, I can’t update all the hundreds of posts manually.

    Examples below from one of the posts :

    1. From the latest PO -> http://www.photofilma.com/images3/screen-from-latest-po.png

    You can see Jigoshop “On”, and others that are On but are not in the previous PO

    Fast Secure Contact Form is Off

    2. From the earlier PO -> http://www.photofilma.com/images3/screen-previous-po-1.png

    You can see Jigoshop is checked to be disabled

    3. same from earlier PO, continued -> http://www.photofilma.com/images3/screen-previous-po-2.png

    Fast Secure Contact Form is enabled

    Plugin Author Jeff Sterup

    @foomagoo

    That is odd. It does look like the settings did not get copied over correctly. Can you restore your database and try update again to 3.0.1?

    I already did that in the very first time, this is already the 3rd time and still with the same issue.

    Anyway, did it again just now, still the same issue … it is global i.e. posts, pages, custom layouts …

    P.S. using the latest WordPress 3.5.2

    Plugin Author Jeff Sterup

    @foomagoo

    The problem with this is that it doesn’t go through each plugin that is disabled individually and adds them to the post in the new field. It just takes the array that is in the old table and moves it to the new able. So if any of the plugins are still disabled then it successfully moved the setting over for the post. It doesn’t reconstruct the array so either they are all there or none of them are there.

    Ok … but in this case it seems the getting the array from the old table is not working properly …

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘[Resolved] Update no good with Shopp ecommerce website.’ is closed to new replies.
Skip to toolbar