"Update Network" hangs, shows "upstream timed out" error in log (7 posts)

  1. Ryan Willis
    Posted 4 years ago #

    NginX + PHP-FastCGI. We have a WordPress Multisite installation using the MultiDB plugin. Updated WordPress to 3.4 and clicked the "Update Network" button. It chugged for a while (a long while, a minute or more), then died with no message (just the wordpress admin & nav bars, no body content). The error log shows:

    [error] 15111#0: *1 upstream timed out (110: Connection timed out) while reading upstream, client: ---.---.---.---, server: ----------------.net, request: "GET /wp-admin/network/upgrade.php?action=upgrade HTTP/1.1", upstream: "fastcgi://", host: "----------------.net", referrer: "https://----------------.net/wp-admin/network/upgrade.php"

    Has anyone run into this before? Thanks in advance for your help.

  2. Which multiDB plugin? There's http://wordpress.org/extend/plugins/shardb/ and http://wordpress.org/extend/plugins/hyperdb/

    (I would think hyperDB to be a better choice since that's wp.com's plugin, and they use nginx, which is why it's on my list to learn!)

  3. Ryan Willis
    Posted 4 years ago #

    It's the MultiDB plugin from premium.wpmudev.org (paid). In all honesty, I'd rather be using HyperDB and may switch in the near future. All that aside though, this seems more like an nginX specific issue to me. I haven't been able to narrow down the bottleneck yet (swamped at work), just thought I would ask if anyone else has seen this before. I'd really like to get it figured out.

  4. I've pinged a forum regular I know who plays nginx :) I'm still not using it yet. But he may know!

  5. Ryan Willis
    Posted 4 years ago #

    Great, thanks :)

  6. I was getting the same error when I did things like import a 800 post WXR file...

    It may not be the correct thing (I'm still poking nginx) but try adding this to your config.

    location ~ \.php$ {
                    fastcgi_read_timeout 10m;


    The fastcgi_read_timeout defaults to 60s, so the 10 minutes may be way too much. I suggest you start with 3m and dial it up as needed.

  7. Ryan Willis
    Posted 4 years ago #

    I actually tried that, but I only went as high as 120 seconds. I'll try more and let ya know. Thanks for your help :)

Topic Closed

This topic has been closed to new replies.

About this Topic