Support » Networking WordPress » Update Network = certificate error

  • Resolved Aren Cambre


    I just upgraded a WordPress Network from 3.4.2 to 3.5.1. I went to Update Network (/wp-admin/network/upgrade.php), upon suggestion of the prompts. After hitting the Update Network button, I get this on the next page (/wp-admin/network/upgrade.php?action=upgrade):
    Warning! Problem updating https://[hostname]/[nameOfFirstBlog]. Your server may not be able to connect to sites running on it. Error message: Peer certificate cannot be authenticated with known CA certificates

    This is wrong. We are using a valid, non-expired certificate issued by InCommon Server CA, and it’s issued to the correct URL for this server.

    How can we get WordPress to ignore this bogus error?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    IIRC update requests are made with curl on your server. Curl uses a bundled set of CA certs. I suspect that’s your problem.

    is there a workaround for this? is there a way to disable just for the upgrade? i don’t see a point for peer authentication just for the updates, unless i get this wrong. please advise.

    Too funny, we were just revisiting this earlier today. We’ll pick it up tomorrow, and hopefully I can post a solution.

    I think I agree, however, that peer authentication is silly for calling the update URLs.

    We just discovered that the hosts file on that server was pointing all hits directly back to itself.

    We have a network appliance that sits in front of our public-facing web stuff that holds all the valid certificates; the servers themselves have self-signed certificates. cURL was correctly objecting because it didn’t like seeing the self-signed certificate. Removing the entry from the hosts file corrected everything.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Update Network = certificate error’ is closed to new replies.