WordPress.org

Forums

Pretty Link Lite
[resolved] Update link doesn' work (4 posts)

  1. madloki
    Member
    Posted 2 years ago #

    Hi everybody,

    is not possible to edit (update) links:

    "ERROR: This Pretty Link Slug is already taken. Check to make sure it isn't being used by another pretty link, post, page, category or tag slug. If none of these are true then check to see that this slug isn't the name of a file in the root folder of your wordpress install."

    Any idea?

    http://wordpress.org/plugins/pretty-link/

  2. cartpauj
    Member
    Plugin Author

    Posted 2 years ago #

    Make sure no other link, pages, posts, categories, tags, or media attachments on your site are using that same slug.

  3. feel528
    Member
    Posted 2 years ago #

    The update function does not appear to be working properly. No duplicate links. Deleted a link because I needed to update the 301 redirect with a new link but it wouldn't allow me as the person above discovered.

    I could't do it even after deleting the link. I had to do it in yoast seo and it works there. Would love to do it all in the same program, PLL if you can check it out.

  4. cartpauj
    Member
    Plugin Author

    Posted 2 years ago #

    We'll be redoing the slugs Pretty Link checks for soon, however their must be something on your site that is using the slug or that error wouldn't show up. It can sometimes be difficult to find the culprit, but 99.9% of the time this isn't a bug.

    Some commonly missed one's are Custom Post Types slugs, Menu Items (yes they get their own slug too), and tags/categories/custom-taxonomies.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic