Support » Plugin: Perfecty Push Notifications » update issue with the plugin “Progressive WordPress”

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Rowinson Gallego

    (@rwngallego)

    Hello @julien-alibert

    I’ve tried to subscribe in your website and noticed that for the registration call your website is returning a 307 redirect to 185.246.45.132:443, and thus the registration fails in the first attempt. If I reload the page, the Perfecty JS SDK attempts to register again by himself and it succeeds. Could you please check your server configuration? I wonder if you have any special configuration in your server or if you use a cache or redirection plugin.

    Details of the request:

    Request URL: https://www.laclefdevoute.fr/wp-json/perfecty-push/v1/public/users
    Request Method: POST
    Status Code: 307 
    Remote Address: 185.246.45.132:443
    Referrer Policy: strict-origin-when-cross-origin
    Plugin Author Rowinson Gallego

    (@rwngallego)

    If this helps in your diagnosis, in the first call there’s no o2s-chl cookie, while in the second call, it’s there. I found the following forum thread where something similar is reported. I don’t know if it’s related to o2switch itself or a cache plugin as mentioned there, probably you need to check with your hosting provider:

    https://forum.opencart.com/viewtopic.php?t=216816&start=40

    Thread Starter Julien ALIBERT

    (@julien-alibert)

    Hello,

    Thank you for your advice and your kindness.
    I disabled XtremCache from my server and removed the forcing https on htaccess.

    Replaced:

    # Redirection vers HTTPS et WWW
    RewriteCond %{HTTPS} off [OR]
    RewriteCond %{HTTP_HOST} !^www\. [NC]
    RewriteCond %{HTTP_HOST} ^(.*)$  [NC]
    RewriteRule (.*) https://www.%1/$1 [R=301,L]

    by

    RewriteEngine On 
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteCond %{HTTPS} !on
    RewriteRule ^(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    I don’t know if that resolves the problem. My technical knowledge is already outdated.

    Thread Starter Julien ALIBERT

    (@julien-alibert)

    I’m still using the cache plugin WP Rocket. PPN runs perfectly on my Samsung S20 (Chrome 90.0.4430.91) but not properly on Windows (Chrome 90.0.4430.93). Effectively the registration fails in the first attempt :/

    I will test on other devices.

    Plugin Author Rowinson Gallego

    (@rwngallego)

    I could see that now the redirection is fixed with the changes you did and the user registration is completed, however the Service Worker registration is not properly done. I will check if I can find something interesting there, if you could enable Debugging in the public widget, that would definitively help.

    Plugin Author Rowinson Gallego

    (@rwngallego)

    You have enabled the “Remove conflicting workers” option, but you shouldn’t because the PWA service worker from Progressive WordPress will be removed. Please deactivate that option first.

    Plugin Author Rowinson Gallego

    (@rwngallego)

    Apart from that there’s a bug in how we install the Perfecty Push Service Worker when there are other Service Workers. I’ve created a ticket here and the fix will be included in the next release: https://github.com/rwngallego/perfecty-push-wp/issues/42

    Plugin Author Rowinson Gallego

    (@rwngallego)

    This has been released in the v1.1.4 version. Please re-open in case you find something additional. Thank you!

    Thread Starter Julien ALIBERT

    (@julien-alibert)

    Hi Rowinson,

    Thank you very much. Now, all work normally. I hope, I’ll can help other WordPress users to turn to Perfecty Push Notifications. It’s a nice work.

    Now, Progressive WordPress have a strong solution to send notification!

    Thank you very much.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘update issue with the plugin “Progressive WordPress”’ is closed to new replies.