Support » Plugin: Disable Comments - Remove Comments & Stop Spam [Multi-Site Support] » Update has site limit for global settings

  • Resolved slackarse

    (@slackarse)


    Hi,

    The latest update has caused comments to re-appear on our multisite network. It appears there is a hard limit of 100 sites that it has been disabled on.

    Can the global setting be made global, as it was before, and not per site?

    Cheers,
    Leigh

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Abid Hasan

    (@abidhasan112)

    Hi @slackarse ,

    Sorry for the inconvenience.
    Actually, we’ve used the get_sites() function which has a default limit set to 100 hence you’re facing an issue for your over 100+ subsites in your network: https://d.pr/i/r2AnuO

    Thanks for reporting this to us! Our dev team is working on overriding this function for unlimited subsites.

    I would recommend you to have some patience with this. We will release a hotfix update for this don’t worry.

    Thank you!

    Plugin Support Abid Hasan

    (@abidhasan112)

    Hi @slackarse ,

    Our dev team just fixed this issue for 100+(unlimited) subsites.
    Can you please download, install and activate this dev version on your Multisite Network and let me know how it goes: https://d.pr/f/OWkyoc

    This will be fixed for your 100+ subsites in your network!

    Let me know how it goes so that we can prepare release!
    Thank you!

    Plugin Support Abid Hasan

    (@abidhasan112)

    Hi @slackarse ,

    We’ve released a new update and resolved this issue for 100+ subsites. If you still having this issue(unchecked over 100+ sites), I would recommend you to roll back to the previous version(v2.1.2) and Save Settings by selecting Everywhere just like before and then update to latest version(v2.2.1). Hope this will work in your case.

    In the next version, we will work on auto-select the subsite when a new subsite will be created so that this will work just like global before.

    If you still facing any issue with this, please create a support ticket from here so that we can assist you: https://wpdeveloper.net/support/new-ticket/

    Thank you!

    Thread Starter slackarse

    (@slackarse)

    Thanks for getting on to that so quickly. I had already rolled back to 2.1.2, I’ll be looking into the latest update today.

    Cheers,
    Leigh

    Thread Starter slackarse

    (@slackarse)

    Hi Abid,

    Thanks for releasing the update so quickly! Apologies for the slow testing time, it looked good on dev, but we can’t simply roll out changes live, as we have an enormous number of sites on our multisite network.

    While the update did fix the listing on the network settings page, only the first 100 sites were checked as disabled, the rest remained unchcked. The “Enable Site Wise settings” option is turned off, yet individual site settings still need to be set. This is completely unusable on a large multsite installation. The page itself is slow to load with a large number of sites requiring checkboxes. I would think a global setting is global, and wouldn’t require the checkboxes.

    Looking at the code changes, it also appears that each page load is also requesting the settings for *every* site in the network, rather than simply looking at a single ‘global’ option.

    As I mentioned in my previous post, can you possbily revert the globally disabled setting to be global, instead of per site?

    Cheers,
    Leigh

    Plugin Support Abid Hasan

    (@abidhasan112)

    Hi @slackarse ,

    Hope you’re doing good today! I understand your purpose!
    We have just released another update today where we’ve added a “Select All” checkbox top of the subsites selection. Also, new subsites will be checked from now so this will work like a global before.

    It seems you’ve saved a setting in previous version(2.2.0) hence the over 100 subsites remain unchecked. Since we have added a Select All checkbox in our latest update today, you can now select all and Save Settings once which will be solved your issue.

    Regarding the large query for the bigger network and slowness, we already have a plan to bring an ajax pagination(in subsites area) in our next version so that this will be reduced.

    I really appreciate your suggestion regarding the global settings. Hopefully, in the future, we will work on it.

    Thank you!

    Thread Starter slackarse

    (@slackarse)

    Hi Abid,

    Thanks again for the quick update. I’m glad you made it so new sites will follow the same settings as well. I look forward to the update which addresses the performance issues and hopefully a solid global option.

    Cheers,
    Leigh

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.