WordPress.org

Forums

Biznez Lite
[resolved] Update generate fatal error (8 posts)

  1. chinkchink
    Member
    Posted 1 year ago #

    Just tried updating to version 1.0.11, no error on update process.
    But when site load, got the following error on page:

    Fatal error: Call to undefined function biznez_nav() in /home/vg007web05/33/76/2017633/web/dev2013/wp-content/themes/biznez-lite/header.php on line 71

    revert back to old version and everythings work again

    suggestions?

  2. chinkchink
    Member
    Posted 1 year ago #

    forgot to mention: older version I am using is 1.0.7

  3. chinkchink
    Member
    Posted 1 year ago #

    Hi got it to work!
    I have a child-theme, and the entire "SketchBoard" folder from the original "biznez-lite" theme was copied into my child-theme folder. So naturally, during upgrade, that copy I made did not get updated...

    Copied the new "biznez-lite/SketchBoard/functions/sketch-theme-support.php" file into the "SketchBoard/functions" folder in my child-theme, and all is well :-)

    cheers!!

  4. Sketch Themes
    Member
    Theme Author

    Posted 1 year ago #

    Hi Chink,

    You are facing this issue due to change in the function prefix from skt_nav() to biznez_nav() in new version of BizNez-Lite which were recommended by the WPORG theme review team. As you already told me that you are using child theme and you have copied functions from function.php from parent theme to functions.php of your child theme. Now the new functions which were used in new update are not available in your child theme's function.php file. To fix this issue you have to copy functions form parent theme's 'functions.php' to you child theme's function.php file once again.

    Best,
    Tikendra

  5. chinkchink
    Member
    Posted 1 year ago #

    Got it! thanks much

  6. lnqesch
    Member
    Posted 1 year ago #

    Hi,

    I installed BizStudio Lite and since then I cannot log into my account, I get an error:

    Warning: Cannot modify header information - headers already sent by (output started at /home4/lnqesch/public_html/wp-content/themes/bizstudio-lite/SketchBoard/functions/sketch-enqueue.php:1) in /home4/lnqesch/public_html/wp-includes/pluggable.php on line 875

    I am just a blogger have no idea about coding, please help!

  7. Gunjan Rai kanungo
    Member
    Posted 1 year ago #

    Hi lnqesch,

    I have fixed this issue in the new version of our theme bizstudio-lite 1.0.7. Please delete your old bizstudio-lite 1.0.6 theme from your ftp and install bizstudio-lite 1.0.7 theme.

    Best,
    Gunjan

  8. Sketch Themes
    Member
    Theme Author

    Posted 1 year ago #

    Hey lnqesch,

    This issue is already fixed in newer version of BizStudio.
    Let us know if you are still facing problem with it.

    Best,
    Tikendra

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic