Support » Fixing WordPress » “Update” function erased post

  • Hi all,
    I was working on a long post (~800 words) that included text, links, graphics and tables. I’m in the habit of frequently clicking on the “update” button in case something unexpected happens. I guess I believed this would save the data in the post in the case of catastrophe.

    The WordPress software started behaving very strangely. When I tried to “update,” the changes wouldn’t show up on the “preview” page. After a few instances of this, I clicked on the “update” button and discovered that 90% of my content just disappeared completely. I wasn’t even working on that particular section of the blog, but was trying to resize some tables below the main content. Why would the “update” function suddenly rewrite the database with changes that I did not make (i.e., erase most of the content)?

    I’m familiar with backing up my data, however my understanding was the “update” function would preserve any changes made while actively writing/editing a post. The “export” function is like a daily/weekly backup. It seems crazy that I am expected to export my data to an XML file every time I edit a post. I suppose the real question for yours truly is, is it really gone forever? Is there some way of retrieving an older version using an FTP application or cPanel interface? . . .A tired and very disappointed WordPress user. . . AYT

Viewing 4 replies - 1 through 4 (of 4 total)
  • I just realized what I’d referred to as the “update” button is actually the “save” button. Unfortunately, that only makes me feel rather more frustrated. Sigh! . . .AYT



    Volunteer Moderator

    I feel your pain. What version of WordPress are you using?

    Hi Mercine,
    Thanks for the reply. I’m using v2.5.1, hosted on my own domain– . . .AYT

    I’m having the same problem. Had v2.5 and upgraded to 2.6.1 – still having the same trouble. Can’t switch from Visual to HTML without losing all the text…clicking Save or Publish gives me a notice asking if I’d like to continue because all changes will be lost. This is from Firefox

    Just tried it in IE – that seems to work.
    But during the post process I get this error:
    Error in my_thread_global_end(): 1 threads didn’t exit…and updating my settings hasn’t helped so far which means I’m on the lookout for another fix. Hopefully it will solve the issue with posting also!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘“Update” function erased post’ is closed to new replies.