Support » Themes and Templates » update file button missing in 2.2!

  • Resolved JArt


    Does anyone know what happened to the “Update File” button to edit a theme? This is so important and it’s missing in wordpress 2.2!

    Where the button used to be is this “If this file were writable you could edit it.” Even themes I could edit before say that. The themes are great but no theme is perfect for everyone. I want to change some things and wordpress 2.2 won’t let me save any changes. This is not good.
    Has anyone else noticed this? I just downloaded 2.2 yesterday. Is mine corrupted or something?
    Please help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hmmm, not sure, and I’m having TONS of problems with 2.2, but it sounds to me like you have a Permissions problem. Did you change hosts/servers also, or just upgraded WP? I have no idea why WP would cause that, but maybe so.

    Basically you need to make your Theme files writeable, which can be done via FTP using the chmod command, or you might be able to do it in your host’s control panel for your website. I forget which Permissions you need, but search around for it, it’s 3 numbers, like 667 or 777.

    If you have FTP, FTP to your site, look in the wp-content/themes/ folder, find your theme, select one of the files, Right Click and see if there’s an option for chmod or Permissions

    I changed my hosting company. Then downloaded the 2.2 version. I had 2.0.2 before.
    Thanks for your advice. I’ll see if I can fine the permissions you spoke about to see if that helps.

    What kinds of problems are you having with 2.2?

    Oh, lordy. I keep discovering new problems with 2.2 that I did not realize I had. At first I thought the upgrade went smoothly. First I noticed 2.2 breaks the old wp-list-cats and wp-list-links, which messed up my Sidebar. I replaced with the new codes (not fun, waste of time). Then I noticed my Admin pages go Blank after I hit “Publish” or “Edit” or “Edit Comment” or edit the theme in Theme Editor. Then I noticed my RSS feed is broken. I have open threads about those later 2 problems, here on the forums.

    I might be dumb. I suck at code. But I have used WP for 2 years, have learned a lot about CSS, PHP, MySQL, etc. And I have Never had this many problems with WP before.

    Presently I am trying to learn how to rollback to 2.0.x.

    Based on my personal experience, I would advise avoiding 2.2 like the plague (possibly 2.1 also, which I skipped). Then again, some people like it and have no problems. I am thankful WP is constantly working on Upgrades, but 2.2 has been a disaster for my site.

    I changed hosts when I upgraded also, like you did. The reason I changed was to get the newer MySQL version required for the newer WP. I know that a different host, could have different default file Permissions, so I guess that might be the problem for you.

    Good luck & keep us posted.

    That sounds like a nightmare! I’m not very good with code either. I can muddle through some of it. I also would like to skip 2.2…
    So I downloaded a older version and when I ran it, it made me upgrade! So I think I’m at 2.2 again.

    I checked out the permissions on my FTP
    “wp-content/themes/ folder, find your theme, select one of the files, Right Click and see if there’s an option for chmod or Permissions”
    and found the chmod.
    “read and write” were checked for “owner”. I checked “execute” as well. Then refreshed wordpress and my “update” button is still missing.
    I scoured my cpanel and couldn’t find anything relating to permissions. When I set up my sql database. I did make sure I had “all Privileges”
    Any other ideas? Do you have that button on your 2.2?

    Yes, I have that button, still in 2.2

    And it sort-of works! If I make a change, and press “Update File,” then I get a BLANK screen which sucks because I have to press Back > Back > Back to get back to the Admin. But whatever 1 change I made, actually “took” — the change is there in my theme, so that much is good.

    Based on your error message of “If this file were writable you could edit it,” the only answer I can think of is File Permissions, and making your theme files Writeable.

    (1) Ask your host if your Theme files are writable. (Don’t say “Theme” if they don’t know WP, just ask them if files in a certain folder are writable).

    (2) Usually the Permissions have a 3-digit number assigned. It’s basically for Read, Write, Execute as you found. Does your FTP / chmod tell you the 3-digit numbers? You might want to search the Codex or this forum for “writeable” and find out for-sure what # you need to have, I think it’s 667 or 777. I think there is a thread that says something like, if 667 doesn’t work for you then try 777. But it could be a security issue so read the other threads from someone who knows more than me.

    Hey, it was my host company! They fixed it and now I’ve got the button again. Sweet.
    You say you don’t know a lot but you helped me. Thanks!!!

    Good luck with your issues with 2.2!
    Sorry, I can’t return the favor and help you.

    I am very happy it helped!

    With help from others on this forum, I will fix my site… eventually… I hope 2.2 is smooth sailing for you from here on.

    By the way, when you alter the theme and press “Update File” — do you get the normal redirect back to that page, or do you get a blank screen? For some reason I get a blank screen, in 2.2.

    I get the normal redirect back to that page…

    I just double-checked the version I’m running and even thought wordpress gave me a screen saying I had to update to 2.2. It actually is letting me use the older version I downloaded.
    So that problem may be a bug with 2.2. Seems like all new updates have bugs.

    mine’s fixed, it was a plugin with a space at the end of it, not 2.2’s fault

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘update file button missing in 2.2!’ is closed to new replies.