Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Update Error – Goal Achieved

  • Two updates ago, 2.4.2, happened and now three of the active forms are showing Goal Achieved incorrectly. One is still showing correctly. I hoped that the newest update would repair it but no luck. I’ve went into each form individually and tried to update the goal, it’s showing correct, but still shows as goal met on the All Forms page and on the website for donors.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Try going to “Donations > Tools > Data” and use the recalculate all forms tool. Also make sure you clear any and all caching, particularly any database caching.

    Let me know how that goes.

    Completed all recalculate options with no luck.

    Shows INF% Goal Achieved on forms that have donations. Shows NAN% Goal Achieved on what has zero donations.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    OK, can you provide me with the following:

    1. A link to your donation forms to see the problem live
    2. Your System Info. You can get that by going to “Donations > Tools > System Info”

    Thanks!

    https://www.scer-ga.org/static/donation/

    ### WordPress Environment ###

    Home URL: https://www.scer-ga.org
    Site URL: https://www.scer-ga.org/wp
    WP Version: 5.1.1
    WP Multisite: –
    WP Memory Limit: 256 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_US
    Permalink Structure: /%postname%/
    Show on Front: page
    Page on Front: Static (#4)
    Page for Posts: Blog (#6)
    Table Prefix Length: wp_qmpi_
    Table Prefix Length: 8
    Table Prefix Status: Acceptable
    Admin AJAX: Accessible
    Registered Post Statuses: publish, future, draft, pending, private, trash, auto-draft, inherit, request-pending, request-confirmed, request-failed, request-completed, in-progress, failed, wc-pending, wc-processing, wc-on-hold, wc-completed, wc-cancelled, wc-refunded, wc-failed, spam, refunded, revoked, cancelled, abandoned, processing, preapproval

    ### Server Environment ###

    Hosting Provider: iPage
    TLS Connection:
    TLS Connection:
    Server Info: Apache/2
    PHP Version: 7.1.1
    PHP Post Max Size: 20 MB
    PHP Time Limit: 120
    PHP Max Input Vars: 1000
    PHP Max Upload Size: 20 MB
    cURL Version: 7.47.0, GnuTLS/3.4.10
    SUHOSIN Installed: –
    MySQL Version: 5.6.41
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ❌ Your server does not have the SoapClient class enabled – some gateway plugins which use SOAP may not work as expected.
    DOMDocument: ✔
    gzip: ✔
    GD Graphics Library: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔

    ### Give Configuration ###

    Give Version: 2.4.3
    Give Cache: Enabled
    Database Updates: All DB Updates Completed.
    Database Tables: ✔ wp_qmpi_give_donors – 1.0✔ wp_qmpi_give_donormeta – 1.0✔ wp_qmpi_give_comments – 1.0✔ wp_qmpi_give_commentmeta – 1.0✔ wp_qmpi_give_sessions – 1.0✔ wp_qmpi_give_logs – 1.0✔ wp_qmpi_give_logmeta – 1.0✔ wp_qmpi_give_formmeta – 1.0✔ wp_qmpi_give_sequential_ordering – 1.0✔ wp_qmpi_give_donationmeta – 1.0
    Give Cache: Enabled
    Give Cache: ✔New Donation✔Donation Receipt✔New Offline Donation✔Offline Donation Instructions✔New User Registration✔User Registration Information✔Donor Note✔Email access
    Upgraded From: 2.4.2
    Test Mode: Disabled
    Currency Code: USD
    Currency Position: After
    Decimal Separator: .
    Thousands Separator: ,
    Success Page: https://www.scer-ga.org/static/donation/donation-confirmation/
    Failure Page: https://www.scer-ga.org/static/donation/donation-failed/
    Donation History Page: https://www.scer-ga.org/static/donation/donation-history/
    Give Forms Slug: /donations/
    Enabled Payment Gateways: PayPal Standard, Offline Donation
    Default Payment Gateway: PayPal Standard
    PayPal IPN Verification: Disabled
    PayPal IPN Notifications: IPN received for #7200 ( 60828002212358738 ) on 03/12/2019 at 16:21. Status N/A
    Donor Email Access: Enabled

    ### Active Give Add-ons ###

    ### Other Active Plugins ###

    Akismet Anti-Spam: by Automattic – 4.1.1
    All In One WP Security: by Tips and Tricks HQ, Peter Petreski, Ruhul, Ivy – 4.3.8.3
    Block Gallery: by Rich Tabor – 1.1.6
    Countdown Wpdevart: by wpdevart – 2.0.3
    Facebook for WooCommerce: by Facebook – 1.9.10
    Intuitive Custom Post Order: by hijiri – 3.1.2
    Jetpack by WordPress.com: by Automattic – 7.1.1
    My Custom Functions: by Space X-Chimp – 4.35
    Premium Blocks for Gutenberg: by Leap13 – 1.4.8
    Printful Integration for WooCommerce: by Printful – 2.0.8
    Stackable – Gutenberg Blocks: by Gambit Technologies, Inc – 1.13.3
    Storefront Footer Bar: by WooThemes – 1.0.4
    Storefront Hamburger Menu: by WooCommerce – 1.2.2
    Storefront Homepage Contact Section: by WooThemes – 1.0.5
    Storefront Product Pagination: by WooThemes – 1.2.4
    Storefront Product Sharing: by WooCommerce – 1.0.6
    Storefront Sticky Add to Cart: by WooThemes – 1.1.9
    Ultimeter – the Ultimate Progress and Goals Meter: by Ben Roberts – 2.0.1
    WooCommerce: by Automattic – 3.5.6
    WooCommerce Blocks: by Automattic – 1.4.0

    ### Inactive Plugins ###

    Benchmark Email Lite: by Coded Commerce, LLC – 2.11
    Instant Articles for WP: by Automattic, Dekode, Facebook – 4.2.0
    JotForm oEmbed: by JotForm.com – 1.2.1
    What The File: by Never5 – 1.5.4
    WooCommerce PayPal Powered by Braintree Gateway: by WooCommerce – 2.2.2

    ### Theme ###

    Name: Storefront
    Version: 2.4.3
    Author URL: https://woocommerce.com/
    Child Theme: No – If you’re modifying Give on a parent theme you didn’t build personally, then we recommend using a child theme. See: How to Create a Child Theme

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    OK, I’m focusing on this form here:
    https://www.scer-ga.org/donations/18/

    Here’s where I’d work on finding the cause of this:

    1) Confirm your Goal settings are correct

    Go to “Edit Form” on that form above, and if you can provide a screenshot of your Form Goal settings that would be helpful.

    After you’ve done that, make sure to do the Form recalculation tools again.

    2) Deactivate potentially problematic plugins
    I’m seeing several things added to that form that might contribute to the problem. For the time-being, please deactivate the following plugins (for testing/confirming the issue):

    • Countdown Wpdevart: by wpdevart
    • Ultimeter – the Ultimate Progress and Goals Meter: by Ben Roberts

    After you’ve done that, make sure to do the Form recalculation tools again.

    3) Disable custom functions
    Keep those plugins deactivated while you do this step too.

    I see the “My Custom Functions” plugin. You can disable those functions with a toggle on the settings screen without deactivating the whole plugin.

    After you’ve done that, make sure to do the Form recalculation tools again.

    If that proves to be part of the problem, provide the code you have in there to me using GIST or Pastebin. I can then chime in on what might be causing the problem from your custom code.

    4) Caching
    The URL you provided has /static in it. And I see “Instant Articles” listed in your Inactive plugins above. That kind of caching could definitely be problematic. But as long as you have the donations in your database, and you have ALL your caching disabled while testing then we should get positive results with any of the above steps.

    Keep me posted on your progress.

    1. Screenshot attached, settings are correct.
    screenshot

    2. Deactivated both plugins

    3. Deleted plugin

    4. Deleted plugin since we weren’t using it anyway.

    Each step had the recalculate function completed. No change. I will start deactivating the remainder of the plugins to see if one of them is in conflict.

    I’m having exactly the same problem, my Goal says “INF% Goal Achieved” Even though only £162.50 of a £1500.00 goal has been met.

    • This reply was modified 6 months, 1 week ago by  BEEF DOCTOR.
    • This reply was modified 6 months, 1 week ago by  BEEF DOCTOR.

    I should also add that that even though my back end donation forms page says “Goal Achieved”, on they front end of my site “0% funded” is displayed, see link.

    Digitalmeat.uk

    • This reply was modified 6 months, 1 week ago by  BEEF DOCTOR.

    I’ve deactivated all the plugins except Give, recalculated, and still no change. I’m at a loss.

    Found the problem but unsure how to correct it. On the goal settings I have it set to percentage of total needed. It shows the error. Changing it to total raised allows it to function. Something in the 2.4.2 update changed the parameters. I tried to change it back to percentage and the error is there again.

    @webdevmattcrom

    Any thoughts?

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    @off1now — thanks for that update about the percentage. I’m going to try to replicate that problem now and will report back.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    With that info I was successfully able to replicate the bug. I reported it here for our developers to fix it.
    https://github.com/impress-org/give/issues/4049

    The workaround for now is as @off1now suggested: You’ll have to use a different display type for your progress bars until a new release is published.

    Thanks for reporting this. We’ll get on it quickly.

    Thanks Matt. Hopefully it’ll be soon.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Update Error – Goal Achieved’ is closed to new replies.