Support » Plugin: HubSpot All-In-One Marketing - Forms, Popups, Live Chat » Update error 7.0.3 (2019.02.12)

  • Resolved chacon88

    (@chacon88)


    Earlier today had a new update of the plugin.

    Soon after updating the plugin I started to receive the following errors:

    Notice: wp_enqueue_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.0.) In /home/nicefilm/public_html/wp-includes/functions.php on line

    When you disable the plugin the error some.

    Can someone help me?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi @chacon88

    The path you’ve added in the error message seems to be missing some information (which would confirm it’s the theme or a plugin).

    Usually when the error occurs in “functions.php” it’s an issue with the WordPress Theme.

    A Notice should not be visible publicly and your site will run normally even if there is a notice.

    Difficult to help without know a little more information (looking at your site).

    Cheers
    Mike

    mbacon40

    (@mbacon40)

    I am running into this as well. This notice appeared after updating the plugin (Contact Form Builder for WordPress – Conversion Tools by HubSpot) to version 7.0.3. This notice only appears when this plugin is active. Changing themes does not make a difference.

    chacon88

    (@chacon88)

    I got in touch with the support of my Theme (Neve – ThemeIsle) to find out if it really is the incompatibility of the theme with the plugin.

    But reinforcing what the mbacon40, the problem is in the plugin and not in the theme, everything was perfect until the update.

    I’ve already got in touch with Hubspot support and they say they can not do anything, that the problem is mine and I turn around.

    Daniel

    (@danyoson)

    Having the same problem here. Disabling the plugin gets rid of the error and the plugin admin page won’t load.

    Hi everyone

    Without seeing the error information it’s impossible to diagnose.

    You can roll back to Version 7.0.2 by removing your current plugin and installing this:

    https://downloads.wordpress.org/plugin/leadin.7.0.2.zip

    However, I would be surprised if this solves anyone’s problem.

    If you try this please let us know the results.

    Mike

    chacon88

    (@chacon88)

    Mike, thank you so much!

    Now the problem has been solved, if possible it would be interesting to let active the downgrade option of the plugin visible to all.

    Daniel

    (@danyoson)

    Mike,
    Did some looking at the 2 versions of the plugin and the problem looks to be on line 59 of leadin/admin/leadin-admin.php the add_leadin_global_admin_style() function calls wp_enqueue_style in the construct of the plugin before the admin_init hook is called and that is the error I am getting.

    If I comment out line 59 version 7.0.3 works fine.

    Hope this helps.

    Daniel

    @webalite,
    do you mind taking a look on what @danyoson wrote? There’s indeed a bug in v7.0.3 as described by him.
    Make sure you have error reporting turned on while developing the plugin.

    Thanks!

    Hi @tyrannous

    I don’t actually work *for* HubSpot – we’re a HubSpot Partner Agency so I come on here to help out… I’ve sent a link to one of the developers at HubSpot so they can look into it.

    We *always* have error reporting turned on and the plugin is working fine on all or installations.

    Cheers
    Mike

    Thanks Mike
    Looks like they fixed it in version 7.0.4

    I wonder if it is a php error_reporting setting on some of our servers that was displaying the notice.

    Daniel

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Update error 7.0.3 (2019.02.12)’ is closed to new replies.