Support » Plugin: Jetpack by WordPress.com » Update Crash

  • Went to update to the 4.5 yesterday version and it crashed my site. Gave me a fatal error when trying to open site. I ended up having to go in via FTP and disable the plugin just to be able to get my site to open again. Unfortunately, I didn’t save the error. I was in such a hurry to get my site back up and running, I didn’t think of it. It was a code issue tho. So currently I still have Jetpack disabled and not sure how to fix this without completely removing the plugin folder and installing the last version again.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same problem here. I’m not skilled enough to start removing plugin folders, etc. — I’ll do more harm than good. I hope WP will receive enough of these complaints that we’ll get a Jetpack update fix soon..!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Could you both try to log in to your site via FTP or CPanel, delete the existing Jetpack plugin folder, and reinstall the plugin manually as explained here:
    http://codex.wordpress.org/Managing_Plugins#Manual_Plugin_Installation

    You’ll find the Jetpack plugin folder here:

    
    wp-content
       plugins
         jetpack - DELETE THIS FOLDER
    

    If you’re not sure how to do this, you can ask your hosting company for help. They should also have documentation explaining how to edit or remove files from your site using FTP or a File Manager in your admin panel.

    Let me know how it goes.

    I already did that and currently uploading the previous version folder. Will see if that works. I was using a lot of Jetpack widgets and apps, so my site is a mess when Jetpack is gone.

    Previously I just went into the FTP and added .bak to the folder to disable it.

    Sorry about jumping in, but I have the same problem with another site. It crashed last night, we used a backup to bring it back up, Jetpack updated overnight and crashed it again making it so the site was only accessible through the CPanel, not FTP. I am open to trying the manual reinstall, but only if it’s not the new version. How can I turn off the automatic updating?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    I am open to trying the manual reinstall, but only if it’s not the new version.

    You can find previous versions of the plugin here:
    https://wordpress.org/plugins/jetpack/developers/

    That said, it might be worth trying to install the most recent version of Jetpack manually, to rule out any issues during the plugin update.

    How can I turn off the automatic updating?

    That depends on how you turned it on. Do you use a service to manage plugins on your site, and automatically update plugins? Jetpack offers such a service, but it’s off by default. You can check if you had it activated Jetpack autoupdates before on this page:
    http://wordpress.com/plugins/jetpack/

    I went in via FTP into the plugin folder, removed the updated Jetpack folder and uploaded (with ftp) the previous version jetpack folder. All I had to do after that was go into my wordpress admin and activate jetpack again. All back to normal. I won’t be updating Jetpack again until there is a fix.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    I’m afraid we won’t be able to prepare a fix without knowing what’s breaking things on your site. πŸ˜”

    I’ve tried to reproduce the issue on my end, but each one of the updates I’ve run seem to work. We also didn’t get any reports from our Beta testers during the Beta period.

    Do you happen to have a test or staging site on the same server, where you could run a test update with WP_DEBUG enabled, so we could find out exactly what’s causing the issue?

    To enable WP_DEBUG, you’d have to add the following to your site’s wp-config.php file:

    
    define( 'WP_DEBUG', true );
    
    if ( WP_DEBUG ) {
    
            @error_reporting( E_ALL );
            @ini_set( 'log_errors', true );
            @ini_set( 'log_errors_max_len', '0' );
    
            define( 'WP_DEBUG_LOG', true );
            define( 'WP_DEBUG_DISPLAY', false );
            define( 'CONCATENATE_SCRIPTS', false );
            define( 'SAVEQUERIES', true );
    
    }
    

    Your wp-config.php file may already include a line that says “define(‘WP_DEBUG’, false);”. You can remove it, and replace it by the code above.

    Once you’ve done so, you can try to update to reproduce the bug. Then, check the wp-content/debug.log file for errors. You can paste the results here. You can then replace define('WP_DEBUG', true); by define('WP_DEBUG', false); in the code above.

    Thanks a lot!

    What is this all about?
    The Jetpack site is inaccessible or returned an error: transport error – HTTP status code was not 200 (500) [-32300]

    I love Jetpack but the recent update (4.5) has screwed up my product listings and won’t display amount of stock. (Running on latest Woocommerce too)

    I disabled every plugin and found that Jetpack’s latest update did this. We need a fix asap, very please. πŸ™

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    @johnebialas @tehcook Could you both please start your own threads, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post

    You’ll want to post your site URLS there and give me as many details about the problem as possible, so I can investigate further.
    If you want your site URL to remain private, you can also contact us via this contact form:
    http://jetpack.com/contact-support/

    Thank you!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Update Crash’ is closed to new replies.