Support » Plugin: WP eCommerce » Update Causes Error –

  • Resolved rottyranch

    (@rottyranch)


    Morning Guys
    Just run the latest version update via wordpress and now cant run wp-eCommerce at all without getting the following error message. Site is being hosted by godaddy and everything within wordpress is kept up to date with all the latest versions and updates.

    Fatal error: Can’t use method return value in write context in /home/brickburg/public_html/wp-content/plugins/wp-e-commerce/wpsc-includes/purchase-log.class.php on line 1532

    Have been forced to turn the plugin off but this is not good as no sales whilst it is turned off.
    Allan

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi, you will find an explanation of the error here:
    http://stackoverflow.com/questions/1075534/cant-use-method-return-value-in-write-context
    If you can’t update to PHP 5.5+ you will have to fix the code by hand.

    This will probably work:

    public function get_total_refunded() {
    $tor = $this->get( ‘total_order_refunded’ );
    return empty( $tor ) ? ‘0.00’ : $this->get( ‘total_order_refunded’ );
    }

    • This reply was modified 2 years, 9 months ago by whitelamp.

    Thanks for that Whitelamp – whilst i am investigating PHP with hosting service. Is there somewhere I can download the version of the plugin, just to get the site running again without loosing all of our work.
    Allan

    Plugin Author Justin Sainton

    (@justinsainton)

    Hi rottyranch,

    Whitelamp is correct – it does sound like you’re on a version of PHP that is outdated and should be updated through your host. GoDaddy should definitely be able to get you up to PHP 5.6 or 7.0.

    In the meantime, we’re pushing a 3.11.6 release to address this issue. It should be out within the hour.

    Thank you so much for your advice, holding off updating other sites until know the new version is ready. Thanks again.

    😉
    Allan

    Plugin Author Justin Sainton

    (@justinsainton)

    @rottyranch

    3.11.6 has been released, addressing the issue you described.

    Thanks Justine

    Worked first time perfectly – 🙂

    Allan

    • This reply was modified 2 years, 9 months ago by rottyranch.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Update Causes Error –’ is closed to new replies.