Support » Plugin: List category posts » Update Caused Fatal Error

  • Resolved debsher

    (@debsher)


    Hi – I just ran the latest update and it caused the following fatal error:
    Parse error: syntax error, unexpected ‘[‘ in …/wp-content/plugins/!list-category-postsbkup/include/lcp-widget.php on line 87
    I tried downloading the plugin and using ftp to update as well and the same thing happened.
    Thanks in advance for your help.
    Deb

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support zymeth25

    (@zymeth25)

    Hi

    This is because your server is running an old version of PHP. Any chance you can upgrade? You need at least PHP 5.4 for the 0.79 version of this plugin to run without errors.

    Thanks for your fast reply! I’ll look into getting pho upgraded.

    I checked with my hosting service and they say they’re already running PHP 5.6….

    Plugin Support zymeth25

    (@zymeth25)

    Hmm, could you do one more thing for me please:

    1. Install and activate this plugin.
    2. Use that plugin to determine which PHP version your WP site is using
    3. Post the result back here

    Thanks!

    Running PHP version: 5.6.27

    Plugin Support zymeth25

    (@zymeth25)

    This is bizarre, I tested the plugin’s code with PHP 5.6 and am 100% sure it works. I cannot explain why you are seeing the error mentioned in your first post. If you have access to your hosting provider’s support I recommend you contact them and describe the issue.

    same here. using 5.3.3 > so found the reason.

    would be nice if the plugin threw an error before trying to update. website was unusable until disabling your plugin by renaming the directory.

    solved – updated to php7

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Update Caused Fatal Error’ is closed to new replies.