Support » Fixing WordPress » Update buttons on Pages grays out and won’t save

  • Hello,

    I just now updated from WordPress 4.5.3 to 4.6 on a PC >using Windows 10<. The ThemeForest theme I am using is Energy.

    I’ve often had good success working on my site via Google Chrome, but no more. Two things are happening, both in Chrome and Microsoft Edge:

    1. The content screen is split by the editor/autosave info, often also hiding formatting icons I need to use (specifically bulleted points and link creation); and…
    2. >>>>When the Page goes into AutoSave on its own, the Update button turns gray, and the word Update won’t return to white on the button, so I can’t save my work. I have read about this glitch extensively in the Forums and am surprised that nothing yet has been done about it since people first started talking about it since WP 3.9. It seems chronic to WordPress rather than to specific themes.

    Here are the steps I have tried in order to get the Update button to work, all with no luck:

    a. In the Forums, I found this thread:
    https://wordpress.org/support/topic/publishsave-draftupdate-button-grayed-out/
    In Chrome, I right-clicked on the >grayed< Update button, and then found the code mentioned some ways down this thread under “Inspect Element”:
    <input name=”save” type=”submit” class=”button button-primary button-large disabled” id=”publish” accesskey=”p” value=”Update”>
    (None of this shows when Update is in white type.)
    I deleted the word “disabled” as recommended in the thread but >do not know how to save this change< so that it will take hold. When I click somewhere else in the code box, “disabled” reappears. And when I delete “disabled” and then immediately click the X in the upper right corner to close the Element code box, the Update button remains gray. More how-to information is needed.

    b. I found this URL in the Forums:
    http://herbmiller.me/2014/04/20/problems-saving-draft-autosaves/
    I couldn’t find the affected code under Inspect Element in order to edit it, and again, if I had, I still don’t know how to save it.

    c. I copied the Page content, including graphics, and pasted it into a Word doc. My editorial changes are saved there, but when I copied and pasted everything back into the Page, none of the graphics transferred back. I could not bear to re-insert them all again. I went back one screen to the old content and clicked Update right quick! Whew.

    d. I dumped the entire Page text into a new WP Page. It worked okay for a few minutes, and then AutoSave kicked in and the Publish button grayed. I hadn’t done much editing, and knew there wouldn’t be a way to save anything, at which point I cancelled the page and came here.

    e. It seems my only recourse is to make just one edit and then immediately hit the Update button. This is tedious because it has to be updated MANY times, and it’s stressful on me because I may not hit Update in time. On my iPad, editing is now impossible: I can’t reach the Update button soon enough because it is way up at the top of the page when the edits just made are closer to the bottom of a very long page.

    f. I have looked for Post Type Switcher, but it doesn’t appear to be in my plug-ins.

    So there you are!

    Questions:

    1. I first saved this page as a Draft, and wonder if that threw things off? I did not know at the time that I had to check the Menus area to be sure it wouldn’t appear there until I was ready to make it Public (it did, as its own Parent, which I didn’t want). I got it off the Menus, and it is now a Published page, Password Protected.

    2. I wonder if “Inspect Element” is the right place to edit code? It is the only place I can find any code like what is talked about in the abovementioned posts. I need to know exactly How to get to a code-editing area, and then How to save the edits once they are made. Apparently, this is automatically known to those who work with code, but I don’t. I am sure I can do all of this on my own with complete instructions.

    3. Is there a character limit to a Page that disables the Update button? If so, is there a way to extend the limit?

    4. It seems the real issue is: why hasn’t anyone at WordPress caught up with this issue yet to fix it globally so that no one experiences this problem ever again? It’s been going on since 3.9. I hope one of the volunteers here has a way to take this message to the developers.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Have you tried:
    -deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    -switching to the default theme to rule out any theme-specific problems.

    I’m admittedly a little scared to do so. The plug-ins I think I can manage, but I don’t know how to switch to the default theme, which sounds scary.

    And should I find a plug-in at fault, what’s next?

    Thank you.

    Also, what about the code lines I asked about?

    There is no magic bullet in these situations. This is just basic troubleshooting – a process of elimination deliberately designed to locate the root cause as quickly as possible by first removing the most obvious and common culprits via a series of (often) temporary steps. Your theme & plugin settings are saved in your database and should be retained for future use.

    You can switch to the default 2016 theme via Appearance -> Themes.

    OK, I bit part of the magic bullet and here is what I know.

    Two of the plug-ins would NOT deactivate: CF Posts and Revolution Slider. The Update button is still graying out.

    I’m going to guess that this is the fault of the Slider, because it wouldn’t install every time I tried. It took the magic of a tech person with my web host to get it to install. Worse, it’s claimed to be a required plug-in. I have no idea what it does, but it doesn’t seem very revolutionary right now.

    Fwiw, the Slider was installed a couple weeks ago, and the Update situation has been bad ever since.

    I clicked on Inspect Element (I opened WP in MS Edge rather than Chrome), searched “disabled” and found this:
    “Saving has been disabled until you’re reconnected.”
    Reconnected?! I’m still online and nothing has disconnected.

    The content field on the screen stopped being split in half, so that’s a good thing, BUT now at the bottom of that field I see “Saving draft…last edited by me at [time].” This must be related to the Update button.

    Next is to use to the Default Theme, but I cannot find it. I went to Appearance>Themes and it shows Energy, Twenty Fourteen, Twenty Fifteen, and Twenty Sixteen. Nothing says Default. More how-to is needed.

    In the meantime, I will reactivate the plug-ins and see which one was splitting the content screen.

    In my case the issue was with extra output (error messages) being printed on admin-ajax.php requests. The problem arises due to AJAX requests expecting proper JSON response, and not some “gibberish” in a shape of error messages 🙂

    In my case it was my plugin, so I could fix it.

    If the plugin is not authored by you, then consider adding define( 'WP_DEBUG', false ) to your wp-config.php file.

    Wish you all best of luck!

    rolfil

    (@rolfil)

    I’m getting the same now. It seems to be that if I start a post with an image the publish button greys out. It seemed to happen with a .jpeg image but when converted to a .png image I didn’t have a problem.

    • This reply was modified 2 years ago by  rolfil.

    After updating to WP 4.8, I have the same issue as Epiq. It seems that this AJAX error occurs whenever WP tries to autosave. Then the ‘Preview’ and the ‘Update’ buttons get disabled. @epic which plugin caused the trouble in your case=

    • This reply was modified 1 year, 11 months ago by  rokzon.
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Update buttons on Pages grays out and won’t save’ is closed to new replies.