• Resolved AndalusianWorld

    (@andalusianworld)


    Site broken with update:

    Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in /home/horseproperties1/public_html/wp-content/plugins/woocommerce-product-sort-and-display/admin/admin-ui.php on line 37

Viewing 9 replies - 1 through 9 (of 9 total)
  • Our site is down too after the update.

    Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in /home/kortools/public_html/wp-content/plugins/woocommerce-product-sort-and-display/admin/admin-ui.php on line 37

    Plugin Author Steve Truman

    (@a3rev)

    Hello @andalusianworld and @touscany

    Have checked and see the error that you are having is an incompatibility with PHP version 5.5.

    PHP stopped support for 5.5 in July 2016 and strongly recommend that it is not used due to security vulnerabilities – see here
    http://php.net/eol.php

    WordPress Requirements state that to run WordPress system config should be
    PHP version 7.2 or greater
    MySQL version 5.6 or greater OR MariaDB version 10.0 or greater
    HTTPS support

    You can read more about that here https://wordpress.org/about/requirements/

    There is a sample letter that you can use on that page to send to your host to upgrade your system. As soon as you upgrade to PHP 5.6 or higher you will not have the issue.

    Regards
    Steve

    I’m running PHP version: 5.6.30 Still broken.

    Plugin Author Steve Truman

    (@a3rev)

    @jmtouscany

    What is the error message that is showing – please post that

    Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in /home/kortools/public_html/wp-content/plugins/woocommerce-product-sort-and-display/admin/admin-ui.php on line 37

    Seeing the following error as well:

    Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in /wp-content/plugins/woocommerce-product-sort-and-display/admin/admin-ui.php on line 37

    I see your comment above about php versions, I’ll look into this, in the mean time, I wanted to point out that WordPress, has a recommendation of php 7.2 or greater, but has a note that WordPress also works on PHP 5.2.4+.

    WordPress Requirements

    Similarly, the requirements listed for this plugin say PHP 5.5 or greater.

    Plugin Requirements

    All’s well now. I was running an old version of PHP.

    Plugin Author Steve Truman

    (@a3rev)

    @jmtouscany

    Thanks for letting me know – will change this thread to resolved and pin it to the top of the forum

    Regards
    Steve

    Plugin Author Steve Truman

    (@a3rev)

    @stndrdsnz

    Thanks for letting me know about that – Had missed updating the plugin requirements – will attend to that

    Regards
    Steve

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Update Broken’ is closed to new replies.