Support » Theme: Appointment » Update broke the site (wants to install bloatware)

  • Resolved bhsmw

    (@bhsmw)


    Upgrading from version 2.7.8 to 2.8.1 breaks the site, as you will have seen from other posts here. Reverting the change fixes the problem.

    It appears that this relates to an extra plugin “Webriti Companion” which is billed as optional but clearly isn’t.

    I am not going to install any additional plugins – themes should be working without any other resources (“bloatware”) required.

    Is this going to be fixed so that the theme will continue working as before or do we need to look for something else?

    Many thanks!

    • This topic was modified 5 months ago by bhsmw.
Viewing 7 replies - 1 through 7 (of 7 total)
  • bhsmw

    (@bhsmw)

    I tested it in the sandbox – even with “Webriti Companion” the site is broken.

    Theme Author webriti

    (@priyanshumittal)

    Dear

    Its not a bloatware, as per the theme review guidelines code structure has been changed, Now a days themes are not allowed to create content directly in theme, so we have created a companion plugin and moved all the code related to the sections in the plugin. Its our companion specially designed for our themes only, its not a third party plugin which our theme rely on.

    Can you clearly mention what issues you have faced after update.

    Thanks
    Priyanshu

    • This reply was modified 5 months ago by webriti.
    • This reply was modified 5 months ago by webriti.
    bhsmw

    (@bhsmw)

    I understand your point about the plugin – I will need to have a better look at the requirements, but have to say that previously no additional plugins were required and the site operated just fine.

    We are using SHK-Corporate child theme (blue) and all the services icons and text on the main page and other content is simply gone. Installing the add-on plugin or making changes, or indeed, switching to Appointment theme has no effect.

    Tried renaming header.php in the child theme as per your suggestion in another post and it still produces a page with main content being blank.

    Current version of the theme is not usable.

    Theme Author webriti

    (@priyanshumittal)

    Kindly update the webriti-companion plugin, this will fix everything but make sure you use the latest version of the appointment theme.

    Let me know did the update worked for your or not.

    bhsmw

    (@bhsmw)

    Hi, thanks for the fix – it’s now working again in my test environment so I guess it can be updated now.

    Having said that, the theme is now generating additional whitespace – any idea why? See here for details.

    Where can I read more about the need for Webriti Companion plugin and what it does? Why does it suddenly not “fit” inside the theme? Also please note that the plugin as listed as “optional” although it’s clearly “required” .

    • This reply was modified 5 months ago by bhsmw.
    • This reply was modified 5 months ago by bhsmw.
    Theme Author webriti

    (@priyanshumittal)

    Somehow forget to check child themes in the plugin, thanks for mentioning this. If we did well than don’t to leave a feedback for us.

    Closing this thread !!!

    So, what about the other issues I listed above?

    Having said that, the theme is now generating additional whitespace – any idea why? See here for details.

    Where can I read more about the need for Webriti Companion plugin and what it does? Why does it suddenly not “fit” inside the theme? Also please note that the plugin as listed as “optional” although it’s clearly “required” .

    The whitespace issue is explained here.

    • This reply was modified 4 months, 3 weeks ago by bhsmw.
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.