Support » Plugin: WP Session Manager » Update Broke Site – Depreciation file issue

  • Resolved WP CMS Ninja

    (@billiardgreg)


    Here is the error that I am seeing after update to 4.0.

    [01-Jan-2019 18:37:49 UTC] PHP Parse error: syntax error, unexpected ‘:’, expecting ‘{‘ in /home/xxxx/public_html/wp-content/plugins/wp-session-manager/includes/deprecated.php on line 15

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Eric Mann

    (@ericmann)

    The plugin leverages scalar return type hints to ensure everything works with the correct types. The error you’re seeing is the error that PHP 5.6 or lower would throw when encountering the following code:

    function function_name(): int {}

    The extra int in there is the return type, which is valid as of PHP 7.0 => http://php.net/manual/en/functions.returning-values.php#functions.returning-values.type-declaration

    Can you confirm the version of PHP you’re using?

    Yes I can confirm that I am running a PHP version less than 7.0. What do you recommend for people that are effected by this?

    Plugin Author Eric Mann

    (@ericmann)

    My first recommendation: upgrade to PHP 7.1 (at least). PHP 7.0 was end of life last month. So was 5.6. Neither are receiving security updates any longer.

    If you can’t upgrade on your own, contact your hosting provider. They can help.

    alorbach

    (@alorbach)

    Its not possible to update to PHP7.1 on any Debian 8 or 9 – unless you compile the whole thing from source which will conflict with the system packages.

    Downgrade the plugin to the latest 3.x Version and make sure it is not accidentally overwritten by updates.

    • This reply was modified 5 months ago by  alorbach.

    This issue also on Ubuntu 16.04 LTS servers (which, BTW, keeps geting security updates for PHP 7.0).

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.