Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Update broke ecommerce

  • Resolved ncalsurfer

    (@dmason)


    I just updated my site and galleries now display a spinning circle of bubbles and NO pricelist / shopping cart.

    This is very disappointing behavior. I already opened a support ticket but am posting here in case someone else experiences the same.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter ncalsurfer

    (@dmason)

    I just downgraded from WordPress 4.9.6 back to 4.9.5 including database changes and ecommerce is working again.

    –For clarity–
    Ecommerce not working:
    Wordpress 4.9.6
    NextGen Gallery 3.0.1
    Nextgen Pro 2.6.0

    Ecommerce working:
    Wordpress 4.9.5
    NextGen Gallery 3.0.1
    Nextgen Pro 2.6.0

    @dmason – I’ll ask our team to test this to see if its something we can duplicate.

    @dmason – can you clarify what’s breaking exactly? ie, Pricelists? Ecom sidebar in Pro Lightbox? Checkout?

    Thread Starter ncalsurfer

    (@dmason)

    Thank you!

    The ecomm sidebar in Pro Lightbox only displays the loading animation of spinning dots and never resolves.

    I will upload a screenshot to ticket #105014

    Thanks again!

    Perfect. Thanks.

    Please update this with a solution of found. I just updated WP to 4.9.6 and now see I should hold off on NextGen.

    Thread Starter ncalsurfer

    (@dmason)

    I found out the reason for the ecommerce side bar not loading under WP 4.9.6 with NextGen Gallery 3.0.1 and Nextgen Pro 2.6.0 plugins was due to my MailChimp Popup running in the “Header Scripts” section in Genesis Theme Settings. I don’t know why but my guess would be WP and NextGen and MailChimp javascript not playing nice with each other.

    I’m investigating other solutions, but so far any use of the MailChimp script causes NextGen Pro Ecommerce to break to the point it cannot be used (literally).

    @dmason – Thanks for the update. We’ll also have our devs take a look and see if there’s any way to safely resolve that conflict from our side.

    Is it specifically for a pop up script? I use Mailchimp as well, but it is in a widget form, not pop up.

    Thread Starter ncalsurfer

    (@dmason)

    Originally I was using the popup script loaded through the Genesis Header Script theme setting. It broke ecommerce for 6 different Imagely themes and several standard WP themes like Twenty Seventeen.

    I can’t speak for your widget @mgraf, but I just tried using a custom HTML widget to load the popup script but this also broke ecommerce. I have to research some other options at this point.

    I have the same problem. When I updated my site NextGen Gallery hasn’t worked properly. Probably It’s bug with JS or compatibility with new version of WordPress. I doesn’t have a backup of site files…

    • This reply was modified 4 years, 4 months ago by sergeygalaev.
    Plugin Author Imagely

    (@imagely)

    Hey @pinot-fish, @sergeygalaev, @dmason, all others who are experiencing issues related (or seem to be related to) NextGEN Pro / NextGEN Plus – Unfortunately, wordpress.org doesn’t allow us to address pro support questions here in the free forum. We can only address NextGEN Gallery [Free] questions only. Please submit a support request through your member account here: http://www.imagely.com/account. Because we need to work with you on this through your member support ticket, I am going to mark this thread resolved.

    Thanks!
    -Becky

    • This reply was modified 4 years, 4 months ago by Imagely.

    I understand that – but there must be some way to publically address that some of these issues have been resolved? Otherwise I am staying far away from the 3.0 update out of fears it will break something that is already working ok.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Update broke ecommerce’ is closed to new replies.