WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Update breaks on MS with no workaround

[Resolved] Update breaks on MS with no workaround

  • kisshomaru
    Member

    @kisshomaru

    See the other thread, however i can’t workaround it. My steps were: put 3.5.2 update first. Tried deleting the plugin entirely, re-installing it, re-updating 3.5.2, as soon as the plugin is enabled for multisite the front end stops with error 500.
    Backend works and I can deactivate it to return site to normal.
    Please fix.

    http://wordpress.org/extend/plugins/plugin-organizer/

Viewing 15 replies - 1 through 15 (of 33 total)
  • kisshomaru
    Member

    @kisshomaru

    Option in settings to: “Selective Plugin Loading: Disable” will return site to normal on 3.5.2, but it does remove the proper functionality of the PO.
    I believe there is a bug in the MU plugin for 3.5.2.

    Jan Dembowski
    Volunteer Mod. & Brute Squad

    @jdembowski

    jasonpaulweber? You’ve already posted a thread about this topic.

    http://wordpress.org/support/topic/great-plugin-update-will-break-site-read-this-first?replies=1

    Please stop posting all of your replies to these topics, you’ve already made your point. Posting to all the threads like that is considered spamming.

    Second? Do not solicit people to contact you off of these forums again here. As you already know that is discouraged.

    Edit: Also? All the old versions are available here.

    http://wordpress.org/plugins/plugin-organizer/developers/

    No one should obtain an old version from off of these forums.

    Plugin Author Jeff Sterup
    Participant

    @foomagoo

    Go to the settings page, Settings->Plugin Organizer in the admin menu, and under Manage MU plugin file at the bottom check Delete and then submit. After that is done and successful click Move and then Submit. Let me know if that caused any errors or fixed anything.

    kisshomaru
    Member

    @kisshomaru

    I am not jason..somth.
    Reading the other threads, I saw the need to post this for MS, as it seems there were some workarounds, they are not working for me.

    That said, Jeff, thanks for the response, I saw the update as well and tried it. I also tried deleting the MU and everything else and re-installing. I had just a few simple rules so it was not too much trouble for me. So now, as soon as I hit activate (network) plugin (so this is on a fresh install with no previous rules left), all sites are down with error 500.
    I should also mention that I have an ssl site network. Everything is ssl.

    Plugin Author Jeff Sterup
    Participant

    @foomagoo

    I just went and activated plugin organizer on a multi site install with 9 different sites on it. I was able to network activate the plugin with no issues. WP 3.5.1

    kisshomaru
    Member

    @kisshomaru

    Tried again installing the 3.0.6 this time, still from scratch, on my 3.5.2. Same 500 error…

    Update: Went back to 2.6.3 that works with 3.5.2 and seems stable. So what is so wrong with the MU file that gets into 500 errors?
    Looking at other threads, I am not the only one doing this.
    Again, my configuration is:
    WP 3.5.2, MS install in a subfolder and https allover.

    Plugin Author Jeff Sterup
    Participant

    @foomagoo

    What is the error that you are getting? You should see something in your php error log.

    kisshomaru
    Member

    @kisshomaru

    As soon as I enable Selective plugin loading in settings on 3.0.6 version, the following php err is logged when trying to access the site and a 500 is thrown in browser:
    [29-Jun-2013 05:55:07 UTC] PHP Fatal error: Call to undefined function wp_get_current_user() in /home/ddd/public_html/aaa/wp-includes/capabilities.php on line 1281

    Line 1281 is this: $current_user = wp_get_current_user();
    from function:
    /**
    * Whether current user has capability or role.
    *
    * @since 2.0.0
    *
    * @param string $capability Capability or role name.
    * @return bool
    */
    function current_user_can( $capability ) {
    $current_user = wp_get_current_user();

    if ( empty( $current_user ) )
    return false;

    $args = array_slice( func_get_args(), 1 );
    $args = array_merge( array( $capability ), $args );

    return call_user_func_array( array( $current_user, ‘has_cap’ ), $args );
    }

    kisshomaru
    Member

    @kisshomaru

    Version 3.0.7 broke both back and front end this time (used to only break front end 3.0 to 3.0.6). Had to manually delete it.

    The error is still related to wp_get_current_user it seems.

    [02-Jul-2013 16:35:57 UTC] PHP Fatal error: Call to undefined function wp_get_current_user() in /home/aaa/public_html/aaa/wp-includes/post.php on line 2121
    Line 2121 is the $user = wp_get_current_user(); from

    function wp_count_posts( $type = 'post', $perm = '' ) {
    	global $wpdb;
    
    	$user = wp_get_current_user();
    Plugin Author Jeff Sterup
    Participant

    @foomagoo

    Try version 3.0.8. I was making a call to wp_count_posts to count the number of plugin groups and create a default group if it didn’t exist. I removed that check in the new version.

    kisshomaru
    Member

    @kisshomaru

    I was able to install and activate version 3.0.8.
    However, we are now back to the original issue: when activating selective loading, the front end gives 500 error. The following is logged again as before:
    [02-Jul-2013 18:07:10 UTC] PHP Fatal error: Call to undefined function wp_get_current_user() in /home/aaa/public_html/aaa/wp-includes/capabilities.php on line 1281

    Plugin Author Jeff Sterup
    Participant

    @foomagoo

    And it gives you this error over and over again if you keep going to the page right?

    kisshomaru
    Member

    @kisshomaru

    Yes, it used to. Now I see though, after I tried again with loading a different page it started to give another one:
    [02-Jul-2013 19:20:35 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 523800 bytes) in /home/aaa/public_html/aaa/wp-includes/query.php on line 1922

    Plugin Author Jeff Sterup
    Participant

    @foomagoo

    Try increasing the allowed memory while the upgrade is performed. You should allocate more than 128mb of memory for wordpress 3.0+.

    kisshomaru
    Member

    @kisshomaru

    Fair enough:
    This is the latest 3.0.9, still installed from scratch:

    [04-Jul-2013 06:07:12 UTC] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 523800 bytes) in /home/aaa/public_html/aaa/wp-includes/plugin.php on line 763

    Thanks for working on this.

    PS. Looking at the other opened threads on more or less the same issue, may I suggest, that if different type of errors are in different places across multiple installs, it might be a memory leak or a specific bad loop on 3.5.2 specifically.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Resolved] Update breaks on MS with no workaround’ is closed to new replies.