Support » Plugin: WP Offload S3 Lite » Update breaks images

  • The latest update (0.9.7) has broken some of my images for my posts but only the ones that have been resized.

    Tried directly accessing one of the images (with “%3Fresize%3D256%252C258” on the end of the string) and I receive the following message:

    Error 0002. The type of image you are trying to process is not allowed.

    Accessing the full image works just fine.

    https://wordpress.org/plugins/amazon-s3-and-cloudfront/

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’m getting this too. I foolishly deleted my entire media library before reverting the update. Now I’ve got a bucket full of images and an empty media library. The saving grace is that because the plugin didn’t delete the files from the bucket, after reverting the plugin the images work again.

    It looks like an easy fix. If they decode the url it comes out as ?resize=256,258 which works like a charm.

    Could you post your diagnostic info here so we can try and replicate. Is it a plugin adding the resize query string?

    Did you update woocommerce at the same time by any chance?

    I am getting the same exact error after updating the plugin all of a sudden none of my pictures show up

    @threesiz – Could you post your diagnostic info here so we can try and replicate. Can you post a URL of a broken image please.

    if i remove the freesize string at the end the image loads

    If you go to AWS > S3 and CloudFront > Support tab, you can download the diagnostic log

    site_url(): http://webakedesign.com
    home_url(): http://webakedesign.com
    Database Name: dbxxxxxx_xxxxxx
    Table Prefix: xxxx_
    WordPress: 4.3.1 Multisite
    Web Server: Apache/2.2.22
    PHP: 5.3.29
    MySQL: 5.1.72-rel14.10
    ext/mysqli: no
    PHP Memory Limit: 256M
    WP Memory Limit: 64M
    Blocked External HTTP Requests: None
    WP Locale: en_US
    Debug Mode: No
    WP Max Upload Size: 59 MB
    PHP Time Limit: 300
    PHP Error Log:
    WP Cron: Enabled
    fsockopen: Enabled
    OpenSSL: OpenSSL 0.9.8o 01 Jun 2010
    cURL: Enabled
    Zlib Compression: Enabled
    PHP GD: bundled (2.1.0 compatible)
    Imagick: Disabled

    Media Files: 540
    Media Files on S3: 538
    Number of Image Sizes: 11

    Bucket: wbdcontent
    Region: us-west-2
    Copy Files to S3: On
    Rewrite File URLs: On

    URL Preview: http://d1fcgpfixwt2dp.cloudfront.net/wp‑content/uploads/2015/10/27162201/photo.jpg

    Domain: cloudfront
    Enable Path: On
    Custom Path: wp-content/uploads/
    Use Year/Month: On
    SSL: request
    Remove Files From Server: On
    Object Versioning: On
    Far Future Expiration Header: Off
    Copy HiDPI (@2x) Images: On

    Active Plugins:
    Akismet (v3.1.5) by Automattic
    Amazon Web Services (v0.3.3) by Delicious Brains
    Diagnostic Tool (v1.0.7) by Richard Bevan, Marcin Cembrzynski
    Jetpack by WordPress.com (v3.7.2) by Automattic
    Magic Action Box (v2.16.9) by Prosulum, LLC
    Pro Sites (Formerly Supporter) (v3.4.3.9) by WPMU DEV
    Regenerate Thumbnails (v2.2.4) by Viper007Bond
    WP Maintenance Mode (v2.0.3) by Designmodo
    WP Multi-Network (v1.6.0) by johnjamesjacoby, ddean, BrianLayman, rmccue
    WP Offload S3 (v0.9.7) by Delicious Brains
    WP Super Cache (v1.4.6) by Automattic
    WooCommerce Social Media Share Buttons (v1.2.1) by Toastie Studio
    WordPress MU Domain Mapping (v0.5.5.1) by Donncha O Caoimh
    Wp Cleanup Optimizer Lite Edition (v2.0.56) by Tech Banker

    Thanks for that, it looks like it is a conflict with Jetpacks Photon module. The images that are broken, are they featured images, images in post content, slider images or something else?

    my site only has background images and a featured images neither of them are showing. I will attempt to disable photon as i don’t use it it was enabled by default on jetpack and update here.

    Iain Poulson you were absolutely correct that fixed the issue. Thank you very much.

    I’m having the same problem using the latest version of jetpack with photon activated, it simply breaks the image url’s and the images stop’s working. Is there anyway of make it work still using photon ? Any suggestions ?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Update breaks images’ is closed to new replies.