Support » Plugin: Essential Addons for Elementor » Update breaks all styling

  • Resolved surewisemike

    (@surewisemike)


    This page looks fine, but if the essential addons plugin is updated to the latest version, the entire thing turns into a single “text editor” block on max-width with none of the stylings, can provide a link with htpassword credentials to this page if needed.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 40 total)
  • Sounds like the same Problem that i had… all Elements are “converted” into one single Text Field.

    I also told that here in Forum… Developers answer… clear Cache. This is the “Basic-all-winning” Answer from the Devs… maybe they think we are total stupid xD

    They always say “cannot reproduce” (also in Tickets)… This Plugin has many Features yes…. but for stability they get a 6 in School… every Update with new Problems.

    I have the same problem as you @surewisemike. Everything is in one section, with all my styling broken. This is not the first issue with this plugin. Before, it reduced the content of the flip-box to the size of an icon. I just got a major whipping from my customers where I’m running this plugin. I have several sites to go and fix now.

    I restored a backup and got the exact same result after updating. Nothing to do with any caching. The update breaks your site the moment you activate it. I ran an update while deactivated, and everything was fine. The moment you activate, it breaks any page with elements from this plugin. No choice but to deactivate. If this is not fixed with the speed of white light, I’ll have to find an alternative…

    It would seem this plugin runs its own cache which you must clear manually in the plugin’s settings page under the “tools” tab. I activated the plugin, cleared the cache there, and now it seems to be working. Too bad I can’t roll back now to see if my content would have stayed intact if I just knew to do this from the start. I am unimpressed by the amount of work this caused for me…

    The Cache Clear hasn’t worked at all for me.

    Plugin Support rafinkhan

    (@rafinkhan)

    @surewisemike @zahost @tkwpweb,

    Hey, guys. First of all, we are really sorry for the inconvenience. Our Dev team is already working on and investigating this issue. In the meantime, you can rollback to a previous version of Essential Addons for now by following this doc: https://essential-addons.com/elementor/docs/faq/roll-back-version-essential-addons/

    Again, we are really sorry for the trouble. Thank you for your patience.

    • This reply was modified 3 months, 2 weeks ago by rafinkhan.

    Same problem HERE 🙁

    Plugin Support rafinkhan

    (@rafinkhan)

    @canonbis,

    Could you please contact us here and provide us a bit more information including your Site URL: support@wpdeveloper.net

    We will have to investigate and resolve it as soon as possible. Thank you.

    @rafinkhan DONE !

    Plugin Support rafinkhan

    (@rafinkhan)

    @canonbis,

    Hi, we have responded back to the ticket you created. Your site seems fine actually. Has the issue been resolved now?

    Please let us know. Thank you.

    It has not been no, this is the live version of the site, our broken version is on a staging site to prevent damaging the business. Please message me if you want the login credentials to the site to see how it looks

    Plugin Support rafinkhan

    (@rafinkhan)

    @surewisemike,

    Hey, there. Could you please email us here: support@wpdeveloper.net

    Thank you.

    Same problem :-/

    My home page is in a single text field. No more buttons, no more footer, and on some other elementor pages, the images don’t display. And maybe some other problems I didn’t saw yet.

    I thought it was because of Elementor’s update, but I see here it’s not.
    My shop is not finished yet, fortunately.

    I cleared the plugin cache, but it didn’t fix the problem. I will try a rollback.

    (sorry for the bad english if it’s not good enought !)

    • This reply was modified 3 months, 2 weeks ago by liliorg.
    • This reply was modified 3 months, 2 weeks ago by liliorg.

    I had the exact similar lay-out problems that surewisemike described. It happened only in Posts (not in Pages), after updating this Essential Addons for Elementor to 3.5.1. Re-installing a back-up solved it, then installing 3.5.1 caused it again, so this plugin is definitely causing the problem.
    I have no time for further analysis, just confirming here that more users have this issue.
    I will wait with updating until I read that this problem is solved.

    Hello again,

    So, all is working fine now, with the plugin v 3.4.0
    All my other plugins are up to date (elementor 2.7.5)

    Hello again.

    One thing to remember is that there are several cache locations which can reproduce the results of your problem even after it was fixed.
    1. Server cache (hosting environment) Never had any trouble here
    2. Browser cache (Chrome is the worst in my opinion)
    3. Plugin cache (plugin specific like EA) a bit redundant if you ask me…
    4. WP Cache (could be a plugin for site cache)
    I would recommend the sequence 3,4,2 before checking the site.

    Depending on your setup, you may not have access to the server cache, but I’ve never had issues there (hence the skip). The results of the error could still remain in your site cache and your browser cache after you have flushed the EA cache. This error doesn’t seem to overwrite the styling, it just prevents it from being loaded. (I could be wrong here)

    Remember also to reload all pages you had open at the time of clearing any cache.

    On my other sites, I cleared the EA cache before updating the plugin. For me, this prevented those sites from breaking as well.

    At first I only cleared the EA cache (which didn’t work), and I didn’t think to clear the other caches as well, so I restored a backup. On the third restore, I cleared the EA cache before the update, and this worked for me. It is a pity that I neglected the other caches during this whole process. It might have saved me a lot of work, but I’m not rolling back anything to check this theory.

    The bottom line is that the results produced by the error could be cached elsewhere as well. It does seem that the error in the plugin’s coding is confined to the cache management only.

Viewing 15 replies - 1 through 15 (of 40 total)
  • You must be logged in to reply to this topic.