• Resolved lpeyton

    (@lpeyton)


    Hello – when I update this plugin, it adds a php handler to the htaccess file:
    AddHandler application/x-httpd-ea-php70 .php

    This addition causes the site to no longer load, but instead download the php files depending on what you link (e.g. clicking on the updates page will download update-core.php)

    Removing the line allows the site to load correctly. The update is also applied correctly.

    Any thoughts on what is happening here? The site is running on PHP version 7.3.17 (WP install is up to date – version 5.5.1

    Thanks for any advice!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi @lpeyton,

    That’s strange. I have consulted about it with our developer and according to them, nothing is added in the htaccess file. We do not modify it with our code.
    There might be some other plugin or something might be conflicting after the User Registration Plugin’s update which could be triggering this.

    To confirm that the User Registration plugin doesn’t do that, we also did a test on our side on the same PHP version and WP version that you have stated.

    For the time being, you can simply remove that line and fix it but in the future updates, if similar things happen then I would recommend you do a conflict test and it might help.

    Regards!

    Thread Starter lpeyton

    (@lpeyton)

    OK thank you. I have been removing the line, but the client prefers to do updates themselves and are not technical enough to do that on their own. It is strange, as I performed a LOT of updates, one by one, and this was the only plugin that interacted with whatever is creating the addition of the handler.
    Thanks!

    Hi @lpeyton,

    We will keep it on our radar and see if we find anything suspicious from our side. We will let you know if there’s anything that we feel is related to it.

    Regards!

    Amanda Giles

    (@shedonist)

    I was having this same issue and I don’t even use this plugin. Every time I saved my Settings > General page (and also when I deactivated plugins?), this same line was added to my .htaccess. It turned out to be some “Endurance Page Cache” PHP file in my wp-content/mu-plugins directory. I had carried this file over from BlueHost to A2Hosting. Removing the 3 endurance cache related files fixed my issue.

    I found the solution in this StackExchange thread. Sharing here in case it helps anyone else struggling with this.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Update adds php handler to htaccess’ is closed to new replies.