Support » Plugin: WooCommerce » Update 5.7 spoiled my site

  • Resolved mahasiv

    (@mahasiv)


    Hello,
    The latest update of woo commerce 5.7 just spoiled my entire site. I have clicked on update about 4 hours back and still it is showing “Step 3 out of 6”. My customers lost all the files that were granted access automatically after payment. Now I am not even able to grant access to them one by one. Check the error message below. I am just scared of the situation if it completes all 6 steps today or tomorrow. See the screenshots below and I pray to God to find the solution.

    https://snipboard.io/Y7gyIX.jpg
    https://snipboard.io/hnIyjA.jpg

    Thanks

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter mahasiv

    (@mahasiv)

    And also please clarify how it is going to effect once all 6 steps completed. Does it delete all PRODUCTS as well? Then it is a BIG BIG problem for me as I have created more than 100 exams as products. Please clarify how it effects PRODUCTS sections of the Plug In?

    It would appear this release was rushed to market without adequate testing. Our hope is they will expedite a rush on a fix asap since so many stores have been impacted. In the meantime you may want to roll back to a previous stable version.

    Thread Starter mahasiv

    (@mahasiv)

    And the latest finding of the 5.7 havoc is I lost all Downloadable file links from all the “Products”. I have hundreds of links in the products and all gone. So, experts… by and large it is a disaster. I am not sure it can be restored by a fix from the team. Only host will help if they have backups.

    Same thing here. On all sites. Download files still in database on export but not showing in products and not available on orders or for customers or in their accounts

    Confirming what most have found – rolling back to 5.6.1 re-instates all orders (and products) that happened before the 5.7 update.

    @mahasiv & @thunderfrog – I have tried many of the previous versions – scarily, the only one that has worked for me is 3.9. It’s dirty, but it’s working. My products, orders, everything is there. It’s not a fix – it will just get your site working somewhat again right now.

    So I killed Woo 5.7 in FTP, my site started working again instantly. I deleted just the files, took an export of all my products and orders just in case, then installed 3.9 (https://developer.woocommerce.com/releases/) and it’s working, but obviously not perfect.

    Plugin Support Adam a11n

    (@adamkheckler)

    @mahasiv @thunderfrog @captaincrank We have had a report of this issue on GitHub here:

    https://github.com/woocommerce/woocommerce/issues/30779

    … but so far our developers have been unable to replicate the problem.

    Please use that GitHub report to share any relevant info you think will help our devs in their investigation, e.g. replication steps starting with a bare WooCommerce site running 5.6.0, system status reports, and so on.

    I’ll mark this as resolved in favor of ongoing discussion happening over on GitHub.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.