Support » Plugin: WooCommerce » Update 4.4.0 Causes Fatal Errors

  • Resolved usat009

    (@usat009)


    Once I updated to 4.4.0 it caused fatal errors in the JetPack Plugin an the WPRocket Plugin, instantly making my backend inaccessible outside of WPEngines recovery mode. I had to role back the website three hours, losing all of today’s work (my fault since i should have backed up before performing the update).

    It seemed like the errors would start appearing across more plugins as it was first WPRocket, and i disabled it temporarily, existed recovery mode, then it failed again, citing Jetpack fatal error, and i wasn’t going to stick around and see what else started failing so i rolled it back to before the WooCommerce update.

    And other users reporting critical failures after this update?

Viewing 15 replies - 31 through 45 (of 45 total)
  • following

    WP Rocket has released version 3.6.4 which fixes the incompatibility with WooCommerce 4.4.

    I had to log in to the WP Rocket website, download the new version, unzip it, and upload it to my test system via FTP. After that the site is working again.

    I’ve uploaded it to my live system as well, and will update WooCommerce to 4.4 tomorrow… after making sure I have a download of version 4.3.3!

    3.6.4 August 18, 2020
    3rd party compatibility: Prevent PHP fatal error following WooCommerce 4.4 update (#3003)
    Bugfix: Prevent PHP notices related to the REST API since WordPress 5.5 (#2985)

    Eveyone update plugin Rocket 3.6.4

    is there an easy way to rollback to 4.3.3 with wget?

    Same here with several plugins… no jet pack installed.

    Delete Woocommerce or disable then everything works….

    Also had to rename wp-rocket plugin folder in file manager. Please fix asap , let’s all send them support emails. Ended up deleting wp-rocket too cause not worth the hassle.

    Hi, I’d like to thank @kurtgschumacher for his comment above, pointing out the solution. As soon as I downloaded wp-rocket version 3.6.4 from https://wp-rocket.me/account/, then uploaded it, via FTP, to my /wp-content/plugins folder, everything went back to normal (running WooCommerce v.4.4.0).

    • This reply was modified 11 months, 1 week ago by .
    • This reply was modified 11 months, 1 week ago by .

    The same thing here. My 3 website running on wp rocket had threw up same critical error. I had to log into my CPanel to delete that plugin because it caused error and Jetpack even logged me out. How can this be fixed?

    i replaced old wp-rocket plugin for new update 3.6.4 and now the backend show with white screen and all panel extended with error, front end its ok. some about it?.

    dmac

    (@darrenmcentee)

    I had this issue on a few websites, with the 4.4.0 Woo update.
    Rename the Woo plugin directory…

    If you set to output your error log using:

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true);
    define( 'WP_DEBUG_DISPLAY', false);

    Get your /wp-content/debug.log output…
    You will see what plugin/theme it’s affecting.
    In my cases, it was:
    – WP Rocket
    – Divi
    – Activity Log
    …among others.

    • This reply was modified 11 months, 1 week ago by dmac.

    I disabled WP-rocket and the wp-admin environment was available, but the frontend of the website still showed the critical error.

    I downloaded woocommerce version 4.3.3 from the following URL at the bottom of the page:
    https://wordpress.org/plugins/woocommerce/advanced/

    WordPress 5.5 allows you to downgrade your woocommerce plugin.
    Just upload the .zip file as a new plugin.
    You will be asked if you want to downgrade to version 4.3.3 click “yes, downgrade” and all should work again.

    WooCommerce 4.4.1 solves it

    I got exactly the same problem. Had to disable WP-Rocket from the server side by renaming the folder. Are there already a solution?

    Yep, WooCommerce 4.4.1 and Wp Rocket 3.6.4 both independently solving the issue.

Viewing 15 replies - 31 through 45 (of 45 total)
  • The topic ‘Update 4.4.0 Causes Fatal Errors’ is closed to new replies.