Support » Plugin: Email Subscribers & Newsletters » Update 3.4.11 doesn’t work

  • Resolved complicword

    (@complicword)


    Hello,
    Plugin doesn’t work anymore since update 3.4.10 and nothing change with the last upadte 3.4.11.
    Sending the form is no long possible. When we click on the send button it writes the form input code (name and email) in the address of the page. There is no more validation message when input mail is empty so it is always possible to click on sent button.
    I saw that the files “es-widget.js” and “es-widget-page.js” have changed a lot. I replaced them with those of version 3.4.9 and validation requests are new active but it is not enough to send the form and have new registered. Now I have a sort of “try later” message.
    So i don’t know how to fix this problem ?
    Can you help me please. I really like your plugin (when it works).
    Thank you

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Icegram

    (@icegram)

    @complicword ,

    Try following steps:
    1. De-activate and re-activate Email Subscribers once. Check if it works after that.
    2. clear cache from your browser and from any caching plugin (if you are using any caching plugin)
    3. check from different browsers than the one you are currently checking from and let me know from which browser it works and doesn’t work.
    4. De-activate all other plugins temporarily except Email Subscribers and then check if it works. If yes, than keep activating other plugins one-by-one to find the conflicting plugin.
    5. check if you have any other error in browser’s console (Ctrl+Shift+J in Windows Chrome)

    If it still doesn’t after trying all 5 steps mentioned above, please send us your website link where you have placed form of Email Subscribers so we can look into it.

    Thank you for taking time to respond to me…
    I did several hours of testing. I did everything you told me… So :
    1 – No change
    2 – No change
    3 – Same problem with safari ,chrome, firefox
    4 – No change
    5 – Yes i have this error: “TypeError: jQuery(…).bindFirst is not a function” in file: es-widget-page.js
    So on this point that is what I thought. This file is in conflict with other jquery script.

    I have a simple jquery lightbox script (not a plugin) in other page than the one where I use your plugin. When i desactivate my lightbox script your plugin seems well worked but it prevents me from using my script.
    I tried to use the plugin “Version Control for Jquery” (V 1.0.8) but nothing change.
    I try to replace my script with plugin wordpress that make lightbox but your plugin does not work anymore.
    I tried too to add code in ‘es-widget-page.js” to resolve the conflict : When i added (jQuery) at the end of line “unit : function(for)”, your plugin and my lightbox worked but it created a conflict with the “jquery.js” wordpress script.
    I do not know very well the javascript and finally I did not find a solution…

    I can’t send you my website link I am developing it with your update (3.4.11) in local.
    What’s too bad again is that everything worked well with your version 3.4.9 but I read the comments about spam so that why I would like to install your update.
    Do you think you can help me ? I hope that my long speech will be useful to find a solution to develop a noconflict script for this very great plugin.
    Thank you

    Please stop sending me emails!!!
    Please stop sending me emails!!!
    Please stop sending me emails!!!
    Please stop sending me emails!!!
    Please stop sending me emails!!!
    Please stop sending me emails!!!
    Please stop sending me emails!!!
    Please stop sending me emails!!!
    Please stop sending me emails!!!
    Please stop sending me emails!!!
    Please stop sending me emails!!!

    Hello @x96816,
    Why this message ?
    Help nobody !

    @complicword

    Thank you for explaining the case in complete detail.
    Kindly allow me some time to check how the jquery version control can be managed.
    I will get back to you once I have checked this on our end.

    @x96816
    May I know which emails are you referring to?

    Plugin Author Icegram

    (@icegram)

    @complicword ,

    Is it solved now?

    Hello @icegram,

    I found myself how fix my bug, i changed jquery version for my lightbox.
    Everything seems to work fine since the wordpress last update 4.9.6 and your last update.
    With GDPR I do a lot of change and i have not tested everything yet (like to send newsletter).
    I will tell you
    Best

    Plugin Author Icegram

    (@icegram)

    @complicword ,

    Great 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Update 3.4.11 doesn’t work’ is closed to new replies.