WordPress.org

Forums

WooCommerce - excelling eCommerce
[resolved] Update 2.015 Breaks Genesis site completely (8 posts)

  1. win58
    Member
    Posted 1 year ago #

    Immediate error after update, reverted to 2.0.14, back to normal.

    See error below, site not functioning

    Catchable fatal error: Argument 1 passed to genesis_get_terms_filter() must be an array, null given in http://www.xxxxx.net/wp-content/themes/genesis/lib/functions/options.php on line 342

    http://wordpress.org/plugins/woocommerce/

  2. Dan
    Member
    Posted 1 year ago #

    Had the same error. 2.0.16 was just uploaded and fixed the error for me.

  3. Mike Jolley
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    It seems there were some merge errors in the 2.0.15 release which caused categories and attribute labels to be hidden. We've resolved this and pushed out 2.0.16 to resolve these issues.

    Please update to 2.0.16 to fix the category/attribute display issues. Apologies for any inconvenience caused.

    http://wordpress.org/plugins/woocommerce/changelog/

    The above should also fix this, as the fix ensures terms (array) are returned. Let me know if not.

    Thanks!

  4. Dan
    Member
    Posted 1 year ago #

    2.0.16 is now causing a white page anytime I add a product to the cart or try to check out. Unable to produce any errors; just a blank white page.

  5. Mike Jolley
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Dan,

    That one I'm not able to reproduce so I think you'll find its memory related.

    Check your WC > System status page, and increase the limit using http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    If you want to see the 'actual' error you are getting you can enable debug http://codex.wordpress.org/WP_DEBUG

  6. Dan
    Member
    Posted 1 year ago #

    Memory is set to 128MB; debugging is set to true. It seems the blank page only occurs when clicking "Proceed to Checkout" from the Cart. However, I can access /checkout/ just fine and finalize the order.

    After deactivating the rest of the plugins (except WooCommerce), I still get the issue.

    I now think my issue is unrelated to the original thread topic.

  7. Mike Jolley
    Member
    Plugin Author

    Posted 1 year ago #

    The actual button? I've seen this before, but I cannot quite remember what was doing it. Any theme template overrides? Post your system status log if you wish.

  8. win58
    Member
    Posted 1 year ago #

    Hi, I've updated to 2.0.16 my similar dev site on localhost with no issues including what Dan is experiencing.
    Will wait a bit before updating live site again.
    Thanks

    PS FYI My overrides are

    /woocommerce/archive-product.php,
    /woocommerce/single-product.php

    using the Genesis Connect Plugin

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic