Support » Plugin: Simple Social Icons » Update 2.0 Ruined Plugin

  • Resolved harrysimonis


    Upon updating to 2.0 just now, the Simple Social icons in the footer of my site turned into tall vertical gray bars with large black letters jumbled in the background, behind the bars. They were previously working fine. Please can you let me know how to fix this?

Viewing 15 replies - 31 through 45 (of 49 total)
  • This should help those that may still be having issues.

    [class^="social-"], [class*=" social-"] {
        display: inline-block;
        width: 1em;
        height: 1em;
        stroke-width: 0;
        stroke: currentColor;

    If you aren’t comfortable editing your theme’s CSS file, and on WordPress 4.7 this can be dropped into the ‘Additional CSS’ in the WordPress customizer found on the wp admin bar when logged in viewing your site.

    you can deactivate new version and then download, install and activate old version from

    @ccochran Thank you this worked for me. I had to clear cache once after adding the code but then they finally displayed correctly. I’ll keep this on file to use for any clients that are having issues.

    While the new version does finally work on one of my clients, I am not upgrading my other clients for now (going to revert that one client as well). It looks like custom coloring each individual icon might be more of a PITA now.

    Can’t figure how to edit my code above, but this css is a little more targeted to only simple social icons, just incase.

    .simple-social-icons [class^="social-"],
    .simple-social-icons [class*=" social-"] {
        display: inline-block;
        width: 1em;
        height: 1em;


    @cochran I have tried both of your codes and my boxes are still coming up wrong. I even tried installing a cache clearer and using that too. Any advice, I’m almost in tears :(.

    Not sure what changed but as of 1100am EST my icons appear to be working. I did not make any additional manual updates

    I did download the SVG Support plug in last night, but at the time it did not seem to help.


    Emily G


    Worked for me!! Thanks!

    • This reply was modified 4 years, 1 month ago by Emily G.

    Clearing browser cache and website cache worked for me right now.

    Here is how we fixed the caching issue. You have to clear the various caches in sequential order: first your server cache, second your CDN, e.g. Cloudflare, use Flush Everything. Third your browser cache. When clearing the browser check all options except for passwords and autofill. You do need to clear “Cookies and other site and plugin data”.

    Thanks again to the dev team for updating this plugin. Icons look great.

    Glad I discovered this on a dev site, so I’m really glad it worked so easily. Thanks!

    I cleared my browser cache (did nothing else), and everything is displaying properly on Chrome now!

    • This reply was modified 4 years, 1 month ago by erinwyso.

    Same problem, clearing cache did not help me either. Jumping in here so I’ll get notified if there’s a fix as well.

    heres the link to my site

    Well, I suppose I would suggest just to use the Fontawesome collection: Very easy to implement. No need fo this plugin anymore. Clearing the cache might have been OK for some (not all) developers, but end-users often don’t know what cache is all about.

Viewing 15 replies - 31 through 45 (of 49 total)
  • The topic ‘Update 2.0 Ruined Plugin’ is closed to new replies.