Support » Plugin: Restore Link Title Field » Update 1.2 broken? Duplicate links inserted

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    I can’t reproduce this. There was a bug in the first released copy of 1.1 that caused this to happen in the Visual mode only, but I fixed that bug. In 1.2, the bug is gone and no duplicate links appear in either mode that I can see. It can’t be happening in 1.2, because I’m no longer binding a handler to the submit.click event, so it can’t fire twice.

    Does this happen in both Visual and Text mode, or only in one of them?

    Also, if you use any form of caching on your site, clear the cache. If you’re somehow loading an older version of the Javascript, then the bug may be gone from the plugin, but still be in your cached version of the JS.

    Hansaplastique

    (@hansaplastique)

    I have this happen in visual mode.

    I’ve uninstalled 1.2, and re-installed 1.0, and now it works fine.
    I’ll trying updating again to 1.2 (before I went from 1.0 -> 1.1 -> 1.2) and get back with the results!

    Hansaplastique

    (@hansaplastique)

    Just upgraded to 1.2 and it generates the link twice again…

    <a title="test title" href="http://google.com">test link text</a><a title="test title" href="http://google.com">test link text</a>

    This happens in visual mode and text mode.

    B.t.w. I’m running WordPress 4.2.1

    Hansaplastique

    (@hansaplastique)

    I stand corrected !

    Otto, you’re right about the caching … my bad.
    I had to clear the image & file cache in Google Chrome and now the plugin work as expected.

    I very much appreciate the plugin and your help!
    Thanks again!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Update 1.2 broken? Duplicate links inserted’ is closed to new replies.