Support » Plugin: WordPress Portfolio Plugin (WP Portfolio) » Update 1.4 Giving Parse Error

  • Resolved 8one8

    (@8one8)


    After updating plugin through plugin admin; site started giving error.
    “Parse error: syntax error, unexpected ******** widget.inc.php on line 14”

    Tried deleting it via FTP; reinstalled from plugin library; same error.

    Dave

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author puravida1976

    (@puravida1976)

    @8one8

    Sorry about that! I was unable to test this before my dev guy got the release out there. I am about to start testing it myself and will also get this report to him for review. He’s usually very good about fixing issues quickly.

    Best regards,

    Brandon

    Plugin Author puravida1976

    (@puravida1976)

    Hello again,

    I tested this a few hours ago and was able to reproduce the issue. However, my dev guy could not reproduce it and he suggests that it is due to outdated PHP versions. I am running PHP 5.3.29 on my test server. Do you mind stating which version you are running? If you can confirm this to be the issue then we can know for certain what caused the parse errors.

    He believes it is related to the newer array shorthand syntax.

    I am a firm believer of staying backwards compatible for as long as possible, but developers are being pushed to always update everything these days. So, it’s a bit of a battle to keep things the way I like them. 😉

    Please let me know the version of PHP when you get a chance.

    Cheers,

    Brandon

    WOW on the service. Awesome.
    You were right; was using legacy PHP. I’m sorry to not have checked that first.

    I updated PHP to 5.6.21 CGI. Was on 5.3.29. Shame on me.

    No action for you. Thanks so much and sorry to have taken your time on a solution I should have checked.

    Dave

    Plugin Author puravida1976

    (@puravida1976)

    Great! I’m just glad we got to the bottom of it. 🙂

    Still, I had my dev write up a PHP 5.3.29 hotfix and he is going to push that out shortly. Due to several old 3rd-party scripts, I have a server that runs PHP 5.3.29 because those scripts break on 5.4.0 or newer. I figure we might as well stay compatible, if not a big deal.

    Anyway, thanks for confirming and updating for posterity. Don’t forget to leave a stellar review for the plugin, if you really LOVE it! 😛

    Cheers,

    Brandon

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Update 1.4 Giving Parse Error’ is closed to new replies.