WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Updat wp 3.9 installed 4.0 Alpha

[Resolved] Updat wp 3.9 installed 4.0 Alpha

  • I pushed the button for an upgrade to 3.9 from 3.8.3. and to my surpise I got 4.0 Alpha! Now most of my plugins don’t works anymore. Anyone know how to rolback to 3.8.3 or 3.9?

Viewing 15 replies - 1 through 15 (of 38 total)
  • Hi,

    I had the same thing. How to get back to 3.9??
    Think I used the NL version.

    Greetz,

    Jasper

    Do you have the WP Beta Tester plugin installed/active, and set to “bleeding edge nightlies”?

    I don’t. I a new build woocomerce webshop.. Live production.. So no testing stuff.

    What Theme are you using? What Plugins do you have active? Is it a single-site or multi-site network install?

    Theme : Twenty Twelve

    Active Plugins (All latest versions):

    – Google Analytics for WordPress
    – Google XML Sitemaps
    – iDEAL Checkout
    – WooCommerce
    – WooCommerce PDF Invoices & Packing Slips
    – WooCommerce PDF Invoices & Packing Slips Premium Templates
    – WP Overnight Sidekick

    Single site.

    Maybe the guys @ nl.wordpress.org made a booboo and packaged the wrong version.

    Same problem here.
    Very annoying. How do I go back. How do I prevent beta or alpha releases to be installed.

    Why is there no information why this is happening or happens.
    How secure is the alpha?
    What kinda problems do I get? How do i roll-back.
    So I can turn off automatic updates so this will never happen again.

    Really dissappointed in WordPress right now.

    Are all of you using the NL language version?

    I do. Willem.deboer sounds Dutch..

    The version that went wrong was the Dutch one.. The other upgrade was US and that went fine.

    Yes, Im using the dutch version.
    An other site of me is also dutch but not infected (yet). Maybe they pulled the update back so not all sites are getting this issue

    Is there anyone who can tell me if I can get back to 3.9?

    I’ve seen this behavior on Icelandic (is_IS) installs, without the beta test plugin, for both single and multi sites.

    I’m using the NL version too. I’m now in deep shit through none of my fault.

    Glad to hear I am not to only one.
    But what do I have to do now?
    Can I rollback? How to prevent this for happening again?

    I just downloaded the file

    https://downloads.wordpress.org/release/is_IS/wordpress-3.9.zip

    and then checked inside the /wp-includes/version.php file:

    <?php
    /**
     * The WordPress version string
     *
     * @global string $wp_version
     */
    $wp_version = '4.0-alpha';
    
    /**
     * Holds the WordPress DB revision, increments when changes are made to the WordPress DB schema.
     *
     * @global int $wp_db_version
     */
    $wp_db_version = 27916;
    
    /**
     * Holds the TinyMCE version
     *
     * @global string $tinymce_version
     */
    $tinymce_version = '4021-20140412';
    
    /**
     * Holds the required PHP version
     *
     * @global string $required_php_version
     */
    $required_php_version = '5.2.4';
    
    /**
     * Holds the required MySQL version
     *
     * @global string $required_mysql_version
     */
    $required_mysql_version = '5.0';
    
    $wp_local_package = 'is_IS';

    So the WordPress 3.9 zip file for is_IS is marked as ‘4.0-alpha’.

    Then I checked the en_US version:

    https://downloads.wordpress.org/release/wordpress-3.9.zip

    <?php
    /**
     * The WordPress version string
     *
     * @global string $wp_version
     */
    $wp_version = '3.9';
    
    /**
     * Holds the WordPress DB revision, increments when changes are made to the WordPress DB schema.
     *
     * @global int $wp_db_version
     */
    $wp_db_version = 27916;
    
    /**
     * Holds the TinyMCE version
     *
     * @global string $tinymce_version
     */
    $tinymce_version = '4021-20140412';
    
    /**
     * Holds the required PHP version
     *
     * @global string $required_php_version
     */
    $required_php_version = '5.2.4';
    
    /**
     * Holds the required MySQL version
     *
     * @global string $required_mysql_version
     */
    $required_mysql_version = '5.0';

    which looks correct.

    So there’s something wrong with the downloads served for the Icelandic version (is_IS) and most likely other language versions, except the English one.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘[Resolved] Updat wp 3.9 installed 4.0 Alpha’ is closed to new replies.
Skip to toolbar