WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Updaing PHP 5.4.x

[Resolved] Updaing PHP 5.4.x

  • Hi When our host performs an update to ph version 5.4.x my site returns an error 500 message.

    I had a look at the php logs and this is what I get.

    [23-Jun-2013 17:29:52 Antarctica/Macquarie] PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so’ – /usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so: undefined symbol: output_globals in Unknown on line 0
    [23-Jun-2013 17:29:52 Antarctica/Macquarie] PHP Fatal error: Directive ‘register_globals’ is no longer available in PHP in Unknown on line 0
    [23-Jun-2013 17:30:36 Antarctica/Macquarie] PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so’ – /usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so: undefined symbol: output_globals in Unknown on line 0
    [23-Jun-2013 17:30:36 Antarctica/Macquarie] PHP Fatal error: Directive ‘register_globals’ is no longer available in PHP in Unknown on line 0
    [23-Jun-2013 17:30:36 Antarctica/Macquarie] PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so’ – /usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so: undefined symbol: output_globals in Unknown on line 0
    [23-Jun-2013 17:30:36 Antarctica/Macquarie] PHP Fatal error: Directive ‘register_globals’ is no longer available in PHP in Unknown on line 0

    The site and pluggins are up-to-date. If anyone has any ideas on what is causing this would love to know.

    Cheers,

Viewing 5 replies - 1 through 5 (of 5 total)
  • Lindsay T
    Member

    @froginapuddle

    This is an error on your host’s side. You could contact them with the error messages you posted.

    Yui
    Participant

    @fierevere

    If you have access to php.ini (if you use shared hosting – ask support instead!)

    suhosin extension – not available in php 5.4 and must be disabled
    register_globals must be removed from php.ini , its not secure and is not supported anymore

    Thanks for the suggestions but they did not work.

    Have fixed this by using my host default php.ini instead of the custom one in my home directory.

    Hey @dylan.keys, How did you fix this I’m having the same issue, very big error log file and have been logged out as well.

    [28-May-2014 11:13:20 America/Chicago] PHP Warning: PHP Startup: Unable to load dynamic library ‘/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/imagick.so’ – /opt/php54/lib/php/extensions/no-debug-non-zts-20100525/imagick.so: undefined symbol: zend_new_interned_string in Unknown on line 0
    [28-May-2014 11:13:20 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module
    Module compiled with module API=20100525

    I’m with hostgator and have just had the php ugraded 2 weeks ago.

    Where is this php.ini located pls?

    Thanks in advance

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Updaing PHP 5.4.x’ is closed to new replies.