Support » Fixing WordPress » Upable to enter blog’s directory

  • I have three WordPress blogs up on my main domain; two are operating fine and the third, which I sent up a couple of weeks ago, was operaitng fine until an hour ago. At that time, I had just posted a post, and then tried to move to the “manage” section – I wanted to adjust the theme – but it wouldn’t let me, gave me an error message saying I didn’t have permission (the same message I reprinted below). When I tried getting bacl to simply viewing the main page, it wouldn’t pull it up. Nor would it let me view any other page or even log in – I got this browsewr message:

    “You don’t have permission to access /waterrights on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

    I checked permissions for all of the foldera dn files, and they all look like – and allow for reading at least. My other blogs still work fine, so I’m guessing it’s not a server problem. An oddity: I FTPed a short htm file in the same directory with this affected blog to see if I could read it, and my brosser gave me the same no permission/no found error message for that.

    My first thought was that folder/file permissions had somehow got changed. But my FTP software reads all of the site just fine – it indicates all the proper files, and permissions for them, are as they should be. Checked through CPanel, and that seems to show the same thing.

    Any reason you can think of why my browser suddenly won’t see the directory where this particular WordPress blog is located, though all the permissions seem to be set right?

    Thanks in advance for any suggestions. Right now I see to be totally blocked out of the directory my blog is in, other than through FTP and CPanel.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Mark (podz)


    Support Maven

    If you are getting a 403 / 404, what is in the cpanel error log?

    Thanks for the suggestion –

    There are of course quite a few lines generally in the error file but the one referring to the directory I’m having a problem with seems to be this:

    [Sun Apr 16 16:56:36 2006] [crit] [client] (13)Permission denied: /home/riden1/public_html/waterrights/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

    So … I took a quick look and don’t see the .htaccess file under /waterrights. Would my next step involve uploading .htaccess? Any suggestions on what I should do next?

    BTW, when I set this site up a couple of weeks ago, I did so through Fantastico – could that have something to do with it?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Upable to enter blog’s directory’ is closed to new replies.