Support » How-To and Troubleshooting » unwanted paragraph tags in the excerpt

unwanted paragraph tags in the excerpt

  • I am getting unwanted <p> paragraph and <br /> tags when adding an explicit excerpt to a post (I mean when I add the excerpt in the post editor’s optional excerpt field).

    I don’t see any of those tags in the optional excerpt field when editing it, but the excerpt includes them once it is published.

    In “Writing Settings” I have unchecked:
    – Convert emoticons like 🙂 and 😛 to graphics on display
    – WordPress should correct invalidly nested XHTML automatically

    WP releases I’m using: 2.6.5 and 2.8.5


Viewing 13 replies - 1 through 13 (of 13 total)
  • First off, wow, you should really update your WordPress versions…

    Make sure that if you want to use html tags you use the html editor and not the visual editor. I’m not even sure what those versions were like. 🙂

    I’m using the html editor only

    The page displaying the excerpt is http://pmi.exportfocus.com
    I need “… continua” to be at the end of the excerpt, on the same line. Unfortunately I get unwanted </p> tag at the end of the excerpt, even if I have not added any <p> tag in the excerpt.

    The code is the following:
    <?php the_excerpt(); ?><a href="<?php the_permalink(); ?>">... continua</a>

    I tried most of remedies — to format the_excerpt() — suggested in this forum. Nothing works.

    Is there a way to get around the problem through style.css ?



    There is some really good advice in these two articles:



    I suggest checking there for an answer. Keep in mind, you will most likely have to upgrade your version of WordPress to do some “more advanced” stuff. You should upgrade your version regardless due to severe security flaws.

    in those 2 pages you can read a lot of helpful advice on how to format excerpts, but unfortunately it doesn’t offer a solution to the problem of adding unwanted <p> tag to manual excerpts.
    Thanks anyway

    To be honest I’d be more concerned about running such an old version of WP than the tags in the excerpts. I bet if you’re running on the latest versions of everything your problem would be solved much quicker and more efficiently.



    Actually, the answer IS in one of the pages I sent you… you just need to know more PHP… try this in your functions.php file:

    function custom_excerpt($text)
       return strip_tags( $text );
    add_filter('the_excerpt', 'custom_excerpt');

    It “might” be the right code based on your versions of PHP… though I’m not entirely sure since they are so old. I could give you the updated way to do this as well, if you upgrade WordPress.



    You could also find out what filter is being applied to the manually entered excerpt and remove it:


    Though I’m not sure what filter is being applied.

    Or you could try to remove all filters being applied to it:


    Anyway I fixed the problem of unwanted adding <p> tag to my manual excerpts, by adding in style.css something like that:

    .excerpt p {
    margin: 5px 0px 0px 0px;

    and in the file.php
    <div class=excerpt><?php the_excerpt(); ?>...

    Patrick, i’m going to update my WP version right now.
    I didn’t update it because of plugins shortcoming when it comes to compatibility with latest WP releases. So, unfortunately I now have to opt to drop some plugins, with some of those really helpful (particularly: “IImage Browser” and “Customizable Post Listings” ).

    wpismypuppet, I tried it but I got the following error message:

    Fatal error: Call to undefined function: add_filter().

    Does it happen because of it is a too old WP release?

    P.S. I am not a PHP coder anyway



    I honestly don’t know what version add_filter() came about… so I’m guessing maybe yours is too old. But I don’t really know. It seems like the css you implemented is doing the trick though…

    If you do manage to upgrade, give it a whirl and let us know. Also, the non-manual use of the_excerpt() does strip out all html. So you could always go that route and then just change the excerpt length. Again, let us know the outcome!

    @placutus: I am glad you decided to upgrade WP version.
    Don’t forget to backup first. Also any plugins that are not compatible
    get rid of them (delete them and not only deactivate). Old, not updated plugins pose a security risk and should be removed.
    For a complete Backup of WordPress see my tutorial: http://bacsoftwareconsulting.com/blog/index.php/wordpress-cat/complete-backup-of-your-wordpress-website/

    Why too many plugins are Not advisable, see: http://bacsoftwareconsulting.com/blog/index.php/wordpress-cat/plugins-in-your-wp-theme/

    @wpismypuppet: Thanks for suggesting my tutorials, I did not even test the code for WP 3.6.5 and probably not even 3.8.5.


    maybe it is off-topic, but i need advice for completing my WP upgrade.
    I have been using the IImage Browser plugin to handle images. It is so flexible and easy to use. Unfortunately, it no longer works with WP 3.3.1 (It works with WP 3.2.1).

    Could anybody suggest me a plugin making the job in a very similar way? Or alternatively, a way to quickly upload the images even without plugin (uploading images, getting thumbnail, setting size of thumbnail while uploading).

    @boutros I keep the number of my plugins at minimum to avoid the risk of not compatibility at any time I need to update my WP version.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘unwanted paragraph tags in the excerpt’ is closed to new replies.