Support » Plugin: jQuery Colorbox » unwanted duplicate image at the end of every “slide show”

  • Hello,
     
    I have a problem with the image display behavior within jQuery Colorbox version 4.6.2.  (WordPress version 4.8)
     
    I am using Colorbox to create image galleries on our website. The problem is that upon uploading, the final image in the gallery is inserted twice, creating an extraneous duplicate at the end of every “slide show”. 
     
    Here is a link to an example of the issue I’m facing – http://archive.thekitchen.org/?p=17706.  If you select the “View images for this event” link on the right side, you’ll notice image 7 is a duplicate of image 6.
     
    I am unsure of how to correct this issue and any help would be highly appreciated. 
     
    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor techotronic

    (@techotronic)

    Hi,

    correct – the plugin takes all images that are linked on the page and puts them into a slideshow.
    The picture in the image, and the six pictures you linked in the gallery.

    Currently, the plugin can’t detect where the images are coming from since that is very hard to implement generically to match any and all WordPress installations with different themes.

    Cheers,
    Arne

    Thread Starter josephbxvi

    (@josephbxvi)

    Hello Techotronic,

    Thanks so much for your help. We really appreciate it!

    If I’m understanding you correctly, you are saying the image is getting duplicated in the slide show due to the fact that it’s getting pulled from the body of the post as well as the gallery? The image in the post isn’t actually in the in gallery so I don’t think that’s the issue.

    In the example post we pointed to earlier, this is the image that is getting duplicated in the slide show.
    http://archive.thekitchen.org/wp-content/uploads/2017/04/antwuan_2.jpg

    and this is the image that’s in the post itself
    http://archive.thekitchen.org/wp-content/uploads/2017/03/IMG_0189_forweb.jpg

    Plugin Contributor techotronic

    (@techotronic)

    haven’t looked at the code in ages. It’s actually grouping the images correctly, the problem is the way you’re inserting the gallery:

    There are 6 images embedded like this:
    <a style="display:none;" href="http://archive.thekitchen.org/wp-content/uploads/2017/06/IMG_1857_forwebx.jpg" rel="colorbox" class="cboxElement hoverZoomLink"><img class="colorbox-17706 last cboxElement hoverZoomLink" src="http://archive.thekitchen.org/wp-content/themes/randyjensen-handcrafted-wp-theme-bc803a6/timthumb.php?src=http://archive.thekitchen.org/wp-content/uploads/2017/06/IMG_1857_forwebx-200x133.jpg&h=111&w=88" title="Photo: Paula Court"></a>

    and they’re grouped together.

    The link itself is also linking to the image above, that’s the reason why it’s shown twice:
    <span id="supplemental-images-link"><a class="cboxElement hoverZoomLink" rel="lightbox" href="http://archive.thekitchen.org/wp-content/uploads/2017/06/IMG_1857_forwebx.jpg">View images for this event (6)<img class="colorbox-17706 last cboxElement"></a></span>

    The duplicated image is http://archive.thekitchen.org/wp-content/uploads/2017/03/IMG_0189_forweb.jpg and not http://archive.thekitchen.org/wp-content/uploads/2017/04/antwuan_2.jpg, at least for me.

    Cheers,
    Arne

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘unwanted duplicate image at the end of every “slide show”’ is closed to new replies.