Support » Plugin: TablePress » Every Other Row After Import is Blank

  • Resolved imapappy

    (@imapappy)


    Hi All …

    I am a brand new Tablepress user and fairly new web designer. I use WordPress with the Enfold theme.

    I love the concept of Tablepress and it seems to be just what I need. However, I have a problem I cant seem to solve.

    I made my spreadsheet using Excel 365. When I import it into Tablepress, every other row in my imported spreadsheet is coming up blank. I don’t know why. I think it may have something to do with the colors that Tablepress uses.

    Also, my header is coming up blank.

    On the original spreadsheet, my header is white letters on blue background and the body is blue letters on a white background. The colors are not getting imported either. Could that be part of the problem?

    Can I get Tablepress to use my original colors and font attributes?

    You can see the problem in http://www.embroiderforyou.biz/AAAAA.

    Can anyone help?

    Thank You.

    Alan

    • This topic was modified 1 month, 1 week ago by imapappy.
    • This topic was modified 1 month, 1 week ago by imapappy.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your question, and sorry for the trouble.

    The cause for this is that your theme is setting white as the font color in tables. To change that, please add this to the “Custom CSS” textarea on the “Plugin Options” screen of TablePress:

    .tablepress th,
    .tablepress td {
    	color: #333333;	
    }

    Your header seems to be empty though. TablePress uses the first row of the table for that. Is your table’s first row (in Excel) really not empty? Can you please try again after exporting the table to a CSV file in Excel and then importing that .csv file into TablePress?

    Table colors are indeed never importing in TablePress, but only the data.

    For more styling ideas, please also see https://tablepress.org/faq/

    Regards,
    Tobias

    Thank You Tobias …

    Your solution worked fine. I will use your info in the faqs to style my spreadsheet on the page.

    No .. the header was there .. it was hidden because of the same problem and appeared after I applied your solution.

    I will close this issue .. thank you for your quick response.

    Alan

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    no problem, you are very welcome! 🙂 Good to hear that this helped!

    Best wishes,
    Tobias

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.