Support » Fixing WordPress » Unusual White Screen of Death Issue

  • Resolved canu

    (@canu)


    Hi,
    We have a White Screen of Death (WSOD) Issue with the Admin panel of a website, the front end is displaying as normal. I cannot currently access the website’s Dashboard.
    On the front end, it even shows that I am logged in but when I attempt to update anything, I receive the WSOD. I have changed the plugin and the them folder names to see if the problem is caused by a conflict with either of them and this didn’t work.
    I had deactivated this website some time ago at the client’s request, during which time the hosting company changed the website’s database credentials for security reasons.
    Could this be the reason why this problem is occurring?

    Any and all help would be gratefully received.

    Thanks!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Howdy!

    Have you tried looking at your error logs? I’m not entirely sure changing credentials would cause a white screen is the reason I ask. If memory serves me right it would trigger a re-install of WordPress or give a message saying that it cannot connect to the database but very rarely an error that would cause a white screen.

    Rajan Vijayan

    (@rajanit2000)

    Hi @canu

    – deactivating ALL (yes all) plugins temporarily to see if this resolves the problem (plugin functions can interfere). If this works, re-activate them individually (one-by-one) to find the problematic plugin(s).
    – If you don’t have access to your Dashboard’s Plugins page, try manually resetting your plugins (no Dashboard access required). Here is another tutorial: http://www.wpbeginner.com/plugins/how-to-deactivate-all-plugins-when-not-able-to-access-wp-admin/ – If that resolves the issue, reactivate each one individually until you find the cause. Also remember to deactivate any plugins in the mu-plugins folder (if you have created such folder). The easiest way is to rename that folder to mu-plugins-old.
    – switching to the unedited default Theme (Twenty Seventeen, etc.) for a moment using the WP dashboard to rule out any theme-specific issue (theme functions can interfere like plugins).
    If you don’t have access to your Dashboard’s Appearance page, access your server via FTP/ SFTP , or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), navigate to /wp-content/themes/ and switch to the default theme by renaming your current theme’s folder by adding “-old” to the end of the folder name. Alternately, you can remove other themes except the default theme (Twenty Seventeen, etc.). That will force your site to use it.
    – If the above steps don’t resolve the issue, try MANUALLY updating. Download WordPress again and unzip it. Access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and delete then replace your copies of everything on the server except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings. Please read the Manual Update directions first.

    Thanks

    Thread Starter canu

    (@canu)

    Hi @rajanit2000,
    Thanks for your suggestions. I renamed the plugins folder previously to deactivate all plugins and the Dashboard was not available.
    I also renamed the folder containing the active folder and again, this didn’t work.
    I neglected to mention that I also restored the files and database from 30 days ago without any success.

    Regards,

    Thread Starter canu

    (@canu)

    Hi @jcastaneda,
    Thanks for coming back to me.
    How do I access the WordPress logs, is it complicated to do?
    I’m non technical so any help would be appreciated.

    Thanks!

    luckychingi

    (@luckychingi)

    Try the following:

    check if all files have the permission is set to 644
    enable debugging by adding define( 'WP_DEBUG', true ); in your wp-config.php file

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Yes, what luckychingi suggested will work as well. If you are not at all completely comfortable with that you can also reach out to your host and ask them where those logs are kept.

    Thread Starter canu

    (@canu)

    Hi @luckychingi & @jcastaneda,

    Thanks for your suggestions.
    After a lengthy conversation with the hosting company, it was established that they could not help me any further so enabling logging on the wp-config file looks like it’s my only option.
    Where does this file display its findings, on the screen so that I will see details instead of a blank screen?
    Apologies for the ‘basic’ question but I’m not a programmer so instructions in very, very simple terms would be appreciated.

    Thanks again.

    Thread Starter canu

    (@canu)

    Hi again,
    I managed to amend the wp-config file and a log file was produced.
    That’s the good news.
    The bad news is that I have a lot of information that I’m not sure what to do with.

    There seems to be 3 distinct categories:

    PHP Deprecated:
    PHP Warning:
    PHP Fatal error: Uncaught TypeError

    Am I correct to assume that I just need to worry about the PHP Fatal Error?

    Rajan Vijayan

    (@rajanit2000)

    @canu

    Is this issue fixed?

    Thread Starter canu

    (@canu)

    Hi @rajanit2000,

    I’m afraid not, I’m still experiencing the same problem.

    Thread Starter canu

    (@canu)

    Hi,

    Does anyone have ideas about how I go about having the log file analysed?

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    makes a slanty face

    Okay, I’m not super happy to hear the host couldn’t help you out. Just for my curiosity who is your host?

    The one that matters it the fatal error. That is when WordPress stops running. What is that message in particular?

    • This reply was modified 3 years ago by Jose Castaneda. Reason: missing bracket
    Thread Starter canu

    (@canu)

    I hear you @jcastaneda, I’m less than impressed with the hosting company as well but not exactly surprised either. The hosting company is GoDaddy.

    An edited version of the fatal error message is as follows:

    [14-Jan-2019 19:20:52 UTC] PHP Fatal error: Uncaught TypeError: Argument 1 passed to WPaaS\Blacklist::plugin_action_links() must be of the type array, string given, called in filepath/class-wp-hook.php on line 288 and defined in filepath/mu-plugins/gd-system-plugin/includes/class-blacklist.php:108

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Hmm. :/

    Looks like it’s a must use plugin. Not sure if you know what that means. In WordPress there are two folders where plugins can reside. The usual wp-content/plugins as well as wp-content/mu-plugins. Those are ones which must be used so a user does not have the ability to deactivate and are always active.

    One way I can think of fixing that would be to rename the mu-plugins folder via FTP or the file manager provided by GoDaddy.

    Let us know if that helps.

    Thread Starter canu

    (@canu)

    Hi @jcastaneda,
    I renamed the mu-plugins folder via FTP and hey presto, I was able to access the Dashboard again.
    I called GoDaddy support and they confirmed that they added this particular folder and that the plugins were there to add additional functionality to the WordPress core but it wasn’t essential for the website to run correctly and often, this folder is empty.
    As this is the case, I think that this case is solved.

    Thanks a million for your help and support in resolving this matter, it’s very much appreciated.

    Best regards,
    canu

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Unusual White Screen of Death Issue’ is closed to new replies.