Support » Plugin: WordPress MU Domain Mapping » Unusual site configuration leads to strange results

  • First off, we’re running a fairly unusual scheme. Our site supports domains, subdomains, and subdirectories:

    Are all valid blog addresses. We’ve been seeing for a long time errors in the log tot he effect of, permission denied to access sunrise.php from xxxxx.php. Since the system worked I just ignored them as background noise.

    Then last week one of our IT guys noticed the errors, and ran ‘restorecon’ on it. Immediately all of the subdirectory sites stopped working. After a few hours of frantically trying things, I disabled this plugin, and changed the permissions on sunrise.php to 000.

    And just like that it all started working again. Until I restarted my browser and tried to log in again. I couldn’t log in to the network from the basic domain. I could log in via one of the subdomains or other URLs, but I couldn’t get into the network control panel which runs off of the primary site.

    I re-enabled sunrise.php by changing its permissions back to 644, and could log in normally. But all the subdomains were broken again. I re-enabled this plugin; still broken. Then changed the permissions of sunrise.php back to 000.

    And now it all works normally again. The plugin is enabled, but the supposedly mandatory sunrise.php cannot be read.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Unusual site configuration leads to strange results’ is closed to new replies.