Support » Plugin: Super Page Cache for Cloudflare » Unstyled content when using with SG Optimizer’s Dynamic Cache

  • Resolved stvinmotion

    (@stvinmotion)


    Thank you for making this awesome plugin!

    I’m on Siteground with SG optimizer & WP Rocket (did the FAQ part)
    On some parts of the website (homepage, posts) I get unstyled content,
    Clearing SG cache solves this for a while but then it happens again.

    Disabling Dynamic Caching on SG Optimizer solves it – so now it’s off.

    Can/should it work together?
    Also SG’s Memcached is on and it seems to work fine.

    One other question I have is: what is the order in which I should purge the cache?
    Should I First cache WP CF super page cache then WP Rocket then SG cache? If not, in what order should it be?

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @stvinmotion ,
    I recommend to use only one page caching system in order to avoid conflicts, so please disable SG and use only this plugin for page caching.

    WP Rocket is already supported as you can see on Third-Party tab. When you clear the WP rocket cache (or it clear the cache by its self) the Cloudflare Cache will be automatically purged thanks to the integration, so you don’t need to go crazy. Make sure all WP Rocket options are enabled on third party tab.

    Ignore WP Rocket alerts if you enable the fallback cache option of this plugin: only one advanced-cache.php file can exist on your wp-content directory and if the advanced-cache.php of this plugin exists, WP rocket show up an alert on backend that you can ignore.

    I suggest you to test also the new option Purge HTML pages only you find on Cache tab, together with the option Auto prefetch URLs in viewport you find on Other tab.

    Best regards

    Thread Starter stvinmotion

    (@stvinmotion)

    Thank you @salvatorefresta

    I deactivated the pluging and now cacheing doesn’t work, I get the following:Page caching seems not working for both dynamic and static pages.

    Error on dynamic page (http://www.stvinmotion.com): Cache status: DYNAMIC – The resource was not cached by default and your current Cloudflare caching configuration doesn’t instruct Cloudflare to cache the resource. Instead, the resource was requested from the origin web server.

    Error on static resource (https://www.stvinmotion.com/wp-content/plugins/wp-cloudflare-page-cache/assets/testcache.html): Unable to find the Cache-Control response header

    I deactivated SG Optimizer, deleted WP rocket, re installed WP CF Super Page Cache but still get this error.

    Thank you

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @stvinmotion ,
    please try to enable the option to strip out response cookies

    Thread Starter stvinmotion

    (@stvinmotion)

    @salvatorefresta “Strip response cookies on pages that should be cached” was enabled. Tries to disable and re-enable but no change.
    Tried to “Reset All” and then strip but same Cache issue.
    Thanks

    Thread Starter stvinmotion

    (@stvinmotion)

    @salvatorefresta I had v4.3.9.1 and it worked fine, wondering how can I get that version to see if this might be a version issue?
    Thanks

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @stvinmotion ,
    I suggest you to use always the latest version to be sure that some minor bugs are fixed

    Thread Starter stvinmotion

    (@stvinmotion)

    @salvatorefresta of course, just trying to figure out why has it stooped working since I deactivated then reactivated. Once I felt how beneficial this plugin is for my website it’s hard to not use it… So, what are other steps I can do to make it work again?
    Thanks

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @stvinmotion ,
    I don’t see the plugin enabled on your website so it’s hard to investigate. Please disable wp rocket, enable the plugin and then re-enable wp rocket. Flush all caches and retry.

    I have too see the plugin in action to help you. If you keep it disabled, it is impossibile for me to help you

    Thread Starter stvinmotion

    (@stvinmotion)

    Thank you @salvatorefresta I deleted the plugin and waited a couple of days, then installed it again and now it works ))

    Closing this thread and will open a new one if needed.
    Thanks again for making this awesome plugin!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Unstyled content when using with SG Optimizer’s Dynamic Cache’ is closed to new replies.