Support » Plugin: PDF.js Viewer » Unsafe Content since last update

  • Hello, since the last update of the plugin, there are several display errors.

    1) It shows the URL as “unsafe content”.

    2) Where the PDF preview should appear, it appears all in red with the following inscription: “Microsoft Defender SmartScreen has blocked this unsafe content”.

    It didn’t appear like this to me before. I leave you a print of the error.

    https://www.dropbox.com/s/pgwxsu9tvsnjswc/2021-10-28_11-21-11.png?dl=0

    Best regards,
    Flor

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Thomas McMahon

    (@twistermc)

    This is a known issue with Microsoft Defender but there are no details around why it thinks it’s insecure. I have a new version coming soon that I hope fixes it, but also there’s no way to tell.

    For now, just tell your browser that the content is safe.

    Hi Thomas, you really made a nice plugin. But I have some problems. I was trying diable ‘document properties’. Is it possible? If not then how can I hide it from the code?

    Best,
    Mou

    Plugin Author Thomas McMahon

    (@twistermc)

    Right now there is no way to disable that. It’s one of many options that I’d have to code in some way of hiding the button and I don’t have a solution to picking and choosing what is shown and what is not.

    If you’re good with code, you can open up pdfjs/web/viewer.php and remove the code, but each time the plugin updates, it’ll come back.

    Hi, Thomas thanks. But exactly which line should I delete?

    Plugin Author Thomas McMahon

    (@twistermc)

    In pdfjs/web/viewer.php you can search for documentProperties and remove the button.

    This is the code to remove:

    
    <button id="documentProperties" class="secondaryToolbarButton documentProperties" title="Document Properties…" tabindex="68" data-l10n-id="document_properties">
    <span data-l10n-id="document_properties_label">Document Properties…</span>
    </button>
    

    Hi, Thomas, sorry for the late reply. I have today tried and after removing the button PDF is not showing really.

    Plugin Author Thomas McMahon

    (@twistermc)

    Unfortunately if that didn’t work, then it’s a bit outside what the plugin can do currently.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.