Unresponsive Script caused by Custom fields (25 posts)

  1. Ryokuns
    Posted 7 years ago #

    ever since i upgraded to wp version 2.3.3 . I received this error that caused by custom fields. it seems to load too many custom fields everytime i'm creating new post or editing post. like 100 custom fields or so till both browser firefox and IE hang .

    how do i fix this?

  2. arickrol
    Posted 7 years ago #

    I've encountered a similar problem on my blog. However, I get the "unresponsive script" error when I click the Write link in my Admin Center.

    Firefox hangs, it seems, when the advanced toolbar shows. How can I figure out what script is causing that? Could it perhaps be Viper's Video Quicktags? That is the only custom entity in the advanced toolbar that I know I have. I think, however, that it may be as a result of the custom fields.

  3. notfainthearted
    Posted 7 years ago #

    I installed 2.5 yesterday and am just now getting the Unresponsive Script error message when opening the Write window. Also, I've noticed that when using the Visual editor, the Link button (to add a href tags to text) brings up a blank dialog box. Could that be the culprit?

  4. arickrol
    Posted 7 years ago #

    I don't know but I'd love for someone, maybe one of the mods, to respond that has the solution to this. Does anyone know if this is a reported bug?

  5. arickrol
    Posted 7 years ago #

    So I was able to look at it a little more closely and it seems there are duplicates. I have 4 copies of several of the custom fields. Does anyone know how to delete them?

    I tried the delete button to no avail. If I could delete the duplicates I wonder if that would solve the issue.

  6. Lester Chan
    Posted 7 years ago #

    Did you guys try disabling plugins in firefox? I used HTML Validator and Firebug in Firefox and they tend to crash my FF when I visit sites that relies of heavy usage of JS like Gmail and Facebook.

  7. arickrol
    Posted 7 years ago #

    Safari throws a slow script error (but it is more tolerant than Firefox). So, below find all the keys and their corresponding values. Maybe we can find something in there.

    164 (shows up 4 times)

    239 (shows up 4 times) wpAjaxa39c5d4924f7e79318da38c99a60ad9c5133e00059b5be4341ebed803edc2639935097a27af866c2e85e7ccc4f9f1456

    240 (shows up 4 times) wpAjax84fc74edafb569781e3791d7288024221715fd9108960f76bccf476117943efd300e3a731fc5fd02f20827eaddf65868

    243 (shows up 4 times) wpAjaxab2ff66ffd09503cb60a9cbfda4e37a9de752d87bc3d3bf6d2aa9a440f4c7bc4a052f2fb618b2e326b5dd06e6aceced4

    244 (shows up 4 times) wpAjax48d32186a2919263a4f69be27d4995b75e99833e4f2f770bbc1564bcb51e506ac95bac156be66e86bd7781f2ae134c29

    245 (shows up 4 times)

    246 (shows up 4 times)

    248 (shows up 4 times)

    251 (shows up 4 times)

    254 (shows up 4 times)

    255 (shows up 4 times)

    256 (shows up 4 times)

    261 (shows up 4 times)

    263 (shows up 2 times)

    265 (shows up 4 times)

    266 (shows up 4 times)

    190 Enclosure (for Podpress, some duplicates)

    A slew (couple hundred) other PodPress entries. PodPressMedia, podPressPostSpecific

    A lot (about 50+) for WP-PostRatings using ratings-average, ratings-score (lots of duplicates in both), ratings users.

    A lot (50+) for Similar Posts and possibly some duplicates.

  8. Does this continue to occur when you disable all the plugins?

  9. arickrol
    Posted 7 years ago #

    Otto: Yes. All the custom fields still load and the unresponsive script still is given.

  10. No, I mean, do the custom fields continue to be added on new posts when you disable your plugins? Obviously, posts that you have which already have all those custom fields will still have the issue.

    None of those custom fields have any meaning to WordPress itself. Something else is adding them.

  11. arickrol
    Posted 7 years ago #

    Otto: I don't know when they are being added but the error is still given when all plugins are disabled.

    I never noticed the fields being created before but they were. With so many entries it is hard to notice a newly created one. I am going to venture onto a limb and say that no new entries are created with all plugins disabled.

    But, I am also going to say that no new entries were created with plugins enabled. At least not recently that I could see.

    That probably doesn't help the diagnostics of this.

  12. angliss
    Posted 7 years ago #

    I just updated my local development environment to 2.5 and am having this same problem on Firefox with all of my plugins disabled. It seems to be that, if I click "continue" twice, Firefox gets through the nonresponsive script just fine.

  13. arickrol
    Posted 7 years ago #

    I have to apologize for the delay in replying. I was out of town this weekend.

    Otto/Other Mods: Have others reported this error in addition to myself? Also, even if new custom fields, on top of the several hundred that were added on my install (Lord knows how), are not added the error is still triggered.

    How can I remove the duplicate custom fields? Do I need to just click through the errors hoping it eventually ends and then manually click the Xs? Or, is a patch available either now or in the foreseeable future?

  14. Ryokuns
    Posted 7 years ago #

    arickrol here's how i do it fix it

    but then it happens again . just now i try to make new post and i saw bunch of custom fields are duplicating itself. manual delete them .. I think one of plugins are being the culprit.

    removing them can only be done by clicking delete manually. there's no way u cld do that when firefox hang with more than 100s of mm_handled rite?

    to otto, yes custom fields still duplicate themself even when plugins are disabled

  15. There have been several issues reported with Custom Fields.


    My advice is currently to either not use custom fields or do not upgrade to 2.5 if you must have them.

  16. Ryokuns
    Posted 7 years ago #

    i didn't use custom scripts and yet it still loaded itself..
    mm_handled 1

  17. There were people having mm_handled errors way before 2.5 came out:

    This is not WordPress adding these. WordPress 2.5 does not use the word "handled" anywhere at all, except in debug/display strings and in comments.

    Here's the results of a full text search in WordPress:

    Searching for: handled
    wp-admin\import\rss.php(25): echo '<p>'.__('Howdy! This importer allows you to extract posts from an RSS 2.0 file into your blog. This is useful if you want to import your posts from a system that is not handled by a custom import tool. Pick an RSS file to upload and click Import.').'</p>';
    wp-admin\includes\dashboard.php(310): // $sidebar_args are handled by wp_dashboard_empty()
    wp-admin\includes\dashboard.php(370): // $sidebar_args are handled by wp_dashboard_empty()
    wp-admin\includes\dashboard.php(376): // $sidebar_args are handled by wp_dashboard_empty()
    wp-admin\includes\dashboard.php(399): // $sidebar_args are handled by wp_dashboard_empty()
    wp-includes\rewrite.php(882): //add in the rules that don't redirect to WP's index.php (and thus shouldn't be handled by WP at all)
    wp-includes\taxonomy.php(1127): * The arguments decide how the term is handled based on the $args parameter. The following
    wp-includes\js\jquery\jquery.form.js(66): * The dataType option provides a means for specifying how the server response should be handled.
    wp-includes\js\swfupload\swfupload.js(898): this.debug("Error Code: Unhandled error occured. Errorcode: " + error_code);
    wp-includes\js\swfupload\swfupload.js(984): this.debug("Error Code: Unhandled error occured. Errorcode: " + errcode);
    Found 10 occurrence(s) in 6 file(s)
  18. arickrol
    Posted 7 years ago #

    Otto: Thanks for the info. Looks like I have a difficult choice. Do a fresh install of WP 2.3.3 and have tags not work properly (display numbers and not real content, WP 2.5 was the only way I could fix the issue).

    Or, use WP 2.5 and never post anything. The custom fields are only used, for me, by plugins. The main ones are Askimet and podPress. I can do without the others but those two make my blog run.

    Here's hoping someone resolves http://trac.wordpress.org/ticket/6540 so I can someday use WP 2.5.

  19. arickrol
    Posted 7 years ago #

    I have just finished deleting all the custom fields via phpmyadmin. The error message no longer shows in Safari. But, and this is the odd part, it still shows in Firefox.

    It is showing when WP tries to load the Categories and Advanced Options sections of /wp-admin/post-new.php

    I'm not sure why but it is a predicament and quite odd.

  20. cuzoogle
    Posted 7 years ago #

    same problem, wish there was actually a solution

  21. mendezki
    Posted 7 years ago #

    wtf? downgrade'r'us.....

  22. mendezki
    Posted 7 years ago #

    I was on my way back to 2.3, accidentally uploaded the 2.5-RC1 files and the problem went away. Hoping for a swift solution though..

  23. craiger
    Posted 7 years ago #

    I'm having this problem, too.

    Here's my thoughts on this:

    I moved a client from blogger to my dev-blog and everything works perfectly on wp2.5.1 ... no issues including NO wayward scripts.

    I then moved everything to his host (a godaddy private-label provider) and then started having problems with several things including the "unresponsive script".

    I really wonder if this an issue related to WP or something to do with the way WP is installed. On my dev-blog, I use fantastico & then use automatic upgrade plugin for my installs. On client install, a wizard/script was used.

    Any thoughts?

  24. mendezki
    Posted 7 years ago #

    I imported a .wxl file from a dev blog into a fresh (my first) 2.5.1 install, when things got a bit strange, custom fields wise. Also tried to import via phpmysql, which didn't work out well. After I uploaded 2.5 and re-imported, things seem to be fine, so far. Both were on the same server though.

  25. heriz
    Posted 6 years ago #

    This started happening to me ONLY after importing my xml backup file. I'm still on 2.6 - I've been using WP for a year and this has never happened (and I've never used the Import function).

    Looks like this might be the problem...

    Surely there must be a way to undo it?

Topic Closed

This topic has been closed to new replies.

About this Topic