WordPress.org

Forums

Gravity Forms WYSIWYG
Unordered List Errors (15 posts)

  1. hopetommola
    Member
    Posted 1 year ago #

    When using the WYSIWYG editor in a paragraph text field, unordered lists appear to format correctly, however upon publishing, each li is assigned to a separate ul.

    We have our form set to submit a post as a draft. The draft is then reviewed by a staff member, and upon approval, published.

    The review of the post seems to be converting:

    <ul>
    <li>one</li>
    <li>two</li>
    <li>three</li>
    </ul>

    to this:

    <ul>
    <li>one</li>
    </ul>
    
    <ul>
    <li>two</li>
    </ul>
    
    <ul>
    <li>three</li>
    </ul>

    https://wordpress.org/plugins/gravity-forms-wysiwyg/

  2. bradvin
    Member
    Plugin Author

    Posted 1 year ago #

    This is a strange one I have not seen before. If you change the editor to text mode does it still do this?

  3. hopetommola
    Member
    Posted 1 year ago #

    If I disable the visual editor for my user account, it does not cause the issue when updating the post.

    If I view it in the visual editor - even if I don't make edits - and hit update, it causes this issue.

  4. bradvin
    Member
    Plugin Author

    Posted 1 year ago #

    There seems to be something interfering with your post content that is not part of the WYSIWYG plugin.

    I just tested this on my local dev site and it works as expected. I created a form that creates draft posts. I also used the body field with "enable WYSIWYG". I then did 2 tests : 1 with the same list as you had above in text mode, and the other test was the same list but in visual mode. Both form submissions created a post with the exact HTML that was entered.

    So it seems to be some other plugin that is not playing nicely on your specific install

  5. hopetommola
    Member
    Posted 1 year ago #

    I am going to run through plugins deactivating, testing, reactivating until I find it. I'll start by deactivating all but GF WYSIWYG and GF itself. I know this is the best way to find the culprit, but when I look at the list of plugins which are network activated and individually active on this blog, I can't imagine which it might be!

    Network Activated:

    • Akismet
    • Easy FancyBox
    • Easy WP SMTP
    • Erident Custom Login and Dashboard
    • Google Analyticator
    • Gravity Forms
    • Jetpack
    • Mail on Update
    • Simple LDAP Login
    • User Role Editor

    Active on this Blog:

    • GF WYSIWYG
    • WP Importer
    • WP Ultimate Search
    • WP Ultimate Search Pro

    I did also implement this change in order to enable the ability to add a custom field to a post from the Quick Editor ... http://wpdreamer.com/2012/03/manage-wordpress-posts-using-bulk-edit-and-quick-edit ... But this list issue existed prior to that.

    I'll keep you posted.
    Thx
    CT

  6. hopetommola
    Member
    Posted 1 year ago #

    Ok. I am running WP 3.8.1. I have deactivated ALL plugins - all of which are up to date - including GF and WYSIWYG. I reverted to Twenty Eleven instead of my twentyeleven child theme.

    It. Still. Occurs.

    I have a draft post. It has lists in it. If I look at it in visual editor, it makes the same issue. If I use text edit, preview from the quick edit screen, no issue.

    So I switched to Twenty Fourteen. Still doing it.

    At this point I'm just getting angry and confused. So I try switching browsers thinking I should try everything. Happening in Chrome and Safari.

    Back to Chrome. Creating a post from scratch, using the text editor. Here's the content:

    <ul>
    	<li>Item One</li>
    	<li>Item Two</li>
    	<li>Item Three</li>
    </ul>
    
    <ul>
    	<li>Item One</li>
    <ul>
    	<li>Sub Item One</li>
    	<li>Sub Item Two</li>
    </ul>
    	<li>Item Two</li>
    	<li>Item Three</li>
    </ul>

    It previews fine. It looks fine in the visual editor. Saved as draft. Edit post - still looks good in the visual editor AND preview. Published post. It looks fine.

    So I turned back to my child theme. This includes the aforementioned Quick Edit mods in a functions.php file. The post I published looks fine. I create a new one, with the same content. Switched between text and visual editor. Previewed. All look fine. Saved draft. Edit post. Still looks fine in visual, text, and preview. Published. Fine still.

    Reactivated GF and WYSIWYG plugins. New test post. All good. Saved as draft.
    Reactivated WP Ultimate Search and Pro. Post saved as draft is fine.

    Network Reactivated Akismet. Post saved as draft is fine.
    Network Reactivated Easy FancyBox. Post saved as draft is fine.
    Network Reactivated WP Easy SMTP. Post saved as draft is fine.
    Network Reactivated Erident Custom Login and Dashboard. Post saved as draft is fine.
    Network Reactivated Google Analyticator. Post saved as draft is fine.
    Network Reactivated Jetpack. Post saved as draft is fine.
    Network Reactivated Mail on Update. Post saved as draft is fine.
    Network Reactivated Simple LDAP Login. Post saved as draft is fine.
    Network Reactivated User Role Editor. Post saved as draft is fine.

    That's all the plugins. It's 100% back to the prior state which resulted in the list formatting issue.

    Returned to my GF form with WYSIWYG editor turned on to re-test. Used the same list as in my test post. Appears properly in both Visual and Text editors in the WYSIWYG fields of my GF. Submitted form.

    It. Still. Occurs.

  7. bradvin
    Member
    Plugin Author

    Posted 1 year ago #

    so if i understand you correctly, you disabled the WYSIWYG plugin and you still got the issue?

  8. hopetommola
    Member
    Posted 1 year ago #

    No - any post, created through the WYSIWYG / GF resulted in the errors.

  9. hopetommola
    Member
    Posted 1 year ago #

    As a matter of fact, I added the ol ul and li tags to my gform_allowable_tags filter in functions.php, and turned off the WYSIWYG editor on one of the three fields on the form.

    I then added the same exact list into both the GF native paragraph text field and the GF WYSIWYG-enabled paragraph text field.

    The list formatting issue occurred only in the list created with the WYSIWYG field. The GF native field was formatted fine.

    Please advise.
    Thx
    CT

  10. bradvin
    Member
    Plugin Author

    Posted 1 year ago #

    I still cannot reproduce your issue, as much as I have tried, and believe me, I have. The WYSIWYG code uses built WP functions to generate the WYSIWYG element.

    Is your form on the front-end being submitted via AJAX?

    Are you saving to a custom post type?

    Perhaps export your form and paste the export XML on pastebin, so I can import it my side to test.

    I can also do a screencast for you showing no issue on my side if you like?

  11. hopetommola
    Member
    Posted 1 year ago #

    I have animations on the form turned on - for conditional fields.
    I am not using a custom post type.

    Form: http://pastebin.com/M08MXYcW

    Holler if you need anything else.

    Much thanks
    CT

  12. bradvin
    Member
    Plugin Author

    Posted 1 year ago #

    ok I see where the problem is now. It is in the Post Content Template.
    So when the body of the post it built up using a content template, then it is doing something funky with the WYSIWYG content. So now we at least know where the problem lies.

    I now need to look into how to fix this.

    I will be in touch...

  13. hopetommola
    Member
    Posted 1 year ago #

    Thank you very much!

  14. hopetommola
    Member
    Posted 1 year ago #

    Holler if there's any way I can assist in testing or otherwise.

    Thx
    CT

  15. hopetommola
    Member
    Posted 1 year ago #

    We had some great hopes and fingers crossed that changes in 3.9 would resolve this. But alas, no luck.

    Have you made progress?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Gravity Forms WYSIWYG
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic