Support » Plugin: Breadcrumb NavXT » Unnamed item in Google Search Console

  • Steve D

    (@steadwell)


    I’m starting a new thread on this issue as my situation seems to differ from other references.

    Recently received error notification from Google search console stating “Fix Breadcrumbs markup for https://www.fusion-culinaire.com/” – the error being “Missing field “itemListElement”. Drilling down on the issue In the console, it shows instances of “Unnamed item”.

    Here is the flagged area for 1 instance (https://www.fusion-culinaire.com/recipes/salads/simple-caprese-salad/) ;

    <nav class="breadcrumbs" aria-labelledby="breadcrumbs-label-19" itemscope itemtype="https://schema.org/BreadcrumbList"><h2 class="screen-reader-text" id="breadcrumbs-label-19">Breadcrumbs navigation</h2><span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to Home page." href="https://www.fusion-culinaire.com" class="home" ><span property="name">Home</span></a><meta property="position" content="1"></span> > <span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to the Recipes category archives." href="https://www.fusion-culinaire.com/recipes/" class="taxonomy category" ><span property="name">Recipes</span></a><meta property="position" content="2"></span> > <span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to the Salads category archives." href="https://www.fusion-culinaire.com/recipes/salads/" class="taxonomy category" ><span property="name">Salads</span></a><meta property="position" content="3"></span> > <span class="post post-post current-item">Simple Caprese Salad</span></nav>

    I’ve attempted the linked and unlinked approach to no avail, though I prefer the unlinked option. The unlinked templates are as follows ;

    <span class="%type%">%htitle%</span>

    Any insight would be greatly appreciated!

    • This topic was modified 4 months ago by Steve D.
    • This topic was modified 4 months ago by Steve D.
    • This topic was modified 4 months ago by Steve D.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Do you find the solution for that? Since 1 month i have the same problem. And i´m confuse with all teh threads and i ask to autor in another thread but doesn´t answer me yet. tx

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.